1

I need to install ffmpeg on Ubuntu aarch64 Architecture. I searched the web but all the guides are about how to install ffmpeg on other Ubuntu distros.

1
  • 2
    One possibility is to upgrade to Ubuntu 15.xx as @incBrain noted the most recent Ubuntu versions include ARM64 binaries as noted here for 15.04 and here for 15.10. – TheSchwa Mar 12 '16 at 1:53
2

I think if you are using Ubuntu 15.XX you can simply run:

sudo apt-get install ffmpeg

if you are on the lower Ubuntu version you can just simply download static builds from here. Or type this in the terminal:

wget http://johnvansickle.com/ffmpeg/releases/ffmpeg-release-64bit-static.tar.xz
tar xf ffmpeg-release-64bit-static.tar.xz
cd ffmpeg-3.0-64bit-static/

Static build of ffmpeg ./ffmpeg will be inside this folder. You can also move it to /usr/local/bin to be able to run it from everywhere.

4
  • My distro is 14.04 but it is aarch64. I tried your solution but i get this error : bash: /usr/local/bin/ffmpeg: cannot execute binary file: Exec format error – Medow Mar 10 '16 at 19:29
  • @Medow ah, I'm sorry didn't read carefully enough, so it's kind of ARM thing? Did you also try to compile ffmpeg? – Dimitri Podborski Mar 10 '16 at 19:45
  • No problem , And yes i did tried to compile it from source, but no success. – Medow Mar 10 '16 at 19:51
  • @Medow I can not find static builds for ARM. But it should be possible to compile it. What was the problem while you was trying to compile it? – Dimitri Podborski Mar 10 '16 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.