4

First of all, let me tell you I am fond of Ubuntu and linux, using it every day since 4-5 years now. I love it, i keep loving it but sometimes it is just frustrating to see how much effort it takes for the simplest things.

I bought an Asus MB168B+ USB monitor which i spent the whole day trying to make it work, without any success.

I googled and googled, installed the drivers, followed guides, tried others solutions. Nothing

The best result I got so far is having a split screen with horrible colors and a distorted resolution:

enter image description here

Here some data and facts:

$ uname -a
Linux xps 3.19.8-031908-generic #201505110938 SMP Mon May 11 13:39:59 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
$ lsb_release -d
Description:    Ubuntu 14.04.4 LTS
$ dmesg
[ 3818.201391] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 3818.201393] usb 1-1: Product: MB168B+
[ 3818.201395] usb 1-1: Manufacturer: DisplayLink
[ 3818.201397] usb 1-1: SerialNumber: EBLMTF251664

When I connect the screen while running, the whole X session crashes, sending me back to the login screen, and the USB screen stays off

If i disconnect and reconnect the usb nothing happens

The "working" screen i got from the picture above was the result of putting a config file for the X server,

/usr/share/X11/xorg.conf.d/52-displaylink.conf
Section "Device"
Identifier      "intel"
driver          "intel"
EndSection

Section "Device"
Identifier      "dl1"
driver          "displaylink"
Option  "fbdev" "/dev/fb1"
EndSection

Section "Monitor"
Identifier "monitor0"
EndSection

Section "Monitor"
Identifier "monitor1"
EndSection

Section "Screen"
Identifier "screen0"
Device "dl1"
Monitor "monitor0"
DefaultDepth 24
EndSection

Section "Screen"
Identifier "screen1"
Device "intel"
Monitor "monitor1"
DefaultDepth 24
EndSection

Section "ServerLayout"
Identifier     "multihead"
Screen      0  "screen0" 1280 0
Screen      1  "screen1" LeftOf "screen0"
Option    "Xinerama" "on"
EndSection

I'm not familiar with X server configurations, but my guess is that it has something to do with that. For sure, it doesnt work out of the box after installing the drivers.

I'd be glad to receive some suggestions after a good working day wasted on this.

Thank you

5

OK finally got mine working perfectly here are the steps I did. This is all done from the terminal, minus the download. I'm brand new to Ubuntu, so far drivers have been a pain in the a.., wifi setup was worse.

Ubuntu 16.04 - fresh install on a Samsung Ativ Book 9 Spin

Note the driver version number and update yours accordingly as it will change in time.

  1. Download driver from http://www.displaylink.com/downloads/ubuntu
  2. Move the driver to somewhere for manipulation. I put mine under ~/driver/displaylink and unzip it
  3. chmod +x displaylink-driver-1.0.335.run

  4. ./displaylink-driver-1.0.335.run --keep --noexec

  5. cd displaylink-driver-1.0.335.run/

  6. Modify the the displaylink-installer.sh with your favorite editor:

Remove this:

detect_distro()  
    {
      if which lsb_release >/dev/null; then
        local R=$(lsb_release -d -s)
        echo "Distribution discovered: $R"
        if [ -z "${R##Ubuntu 14.*}" ]; then
          SYSTEMINITDAEMON=upstart
        elif [ -z "${R##Ubuntu 15.04*}" ]; then
          SYSTEMINITDAEMON=systemd
        fi
      else
        echo "WARNING: Unknown distribution, assuming defaults - this may fail." >&2
      fi
    }

Replace with:

detect_distro()  
{
  if which lsb_release >/dev/null; then
    local R=$(lsb_release -d -s)
    echo "Distribution discovered: $R"
    SYSTEMINITDAEMON=systemd
  fi
}
  1. sudo apt-get install dkms (This was from an error I was getting regarding missing packages for dkms, whatever that is)

  2. sudo ./displaylink-installer.sh install

  3. Go to settings > displays I saw it listed at this point but only a black screen on the Asus monitor. Unplug it
  4. Restart, plug in the monitor and it magically worked for me. Clear as mud

Solution is from a mix of:

Note I really only followed the coding struggles article and was missing the dkms packages that were mentioned in the displaylink.com article.

3

Just a few days ago, displaylink released a new driver that works much better, seemingly. Right off for me, on 16.04, with one caveat: it was unable to start the service it needs to run because I was on UEFI "safeboot", and the failure was very silent.

Going into bios and turning off safeboot fixed it for me. There's also mokutils, though that didn't work for me.

Finally, there is a nice package on github for debian, though they hadn't updated with the new driver, so it wasn't quite working for me--just nearly. I messaged the repo maintainer, however, and by the next morning he had updated it. (Later edit: next computer I had, I used it, and it worked great for me.)

I believe distro detection is now resolved in the most recent version.

1

My monitor is ASUS MB169B+, and my os is Ubuntu 14.04 LTS.

  • What I do to make it work as follows:

    1. Download displaylink package from http://www.displaylink.com/downloads/ubuntu
    2. Unzip the package, and cd to the folder
    3. Run

      ./displaylink-driver-1.2.65.run

    The first time it prompted that missing packages for dkms;

    1. Run

      sudo apt-get install dkms

    2. again run

      ./displaylink-driver-1.2.65.run

    And now it should install successfully;

    1. reboot the system;
    2. In the setting menu, I can set my display now, and it works well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.