0

I am new to Ubuntu, and I am trying to install Steam on a 64 bit Ubuntu partition on my Macbook. My first try, I went to the Steam webpage, installed the installer there and opened it with the default option. I went through the install process and came up with an error stating that I was missing some 32 bit libraries. I searched the error on firefox and did what it told me to. I tried opening Steam again, resulting in a different error. (more 32 bit libraries, this time it was libGL) I looked this up as well and followed the instructions from http://ubuntuforums.org/showthread.php?t=2233005. I tried turning Steam on again, resulting in the same error. After this, I decided to start over from scratch, so I deleted Steam through the application store and reinstalled it. I then tried to open Steam, resulting in nothing. No error messages, no terminal windows, nothing at all. I waited for 10 minutes before trying again, still nothing.

What am I doing wrong? Thanks in advance for your help.

EDIT: Organic Marble suggested typing "Steam" into terminal, which resulted in this message:

(gnome-terminal:1967): GLib-GIO-CRITICAL **: g_settings_get: the format string may not contain '&' (key 'monospace-font-name' from schema 'org.gnome.desktop.interface').  

This call will probably stop working with a future version of glib.

It also allowed Steam to open once again. Running Steam gave me these messages:

(gnome-terminal:3301): GLib-GIO-CRITICAL **: g_settings_get: the format string may not contain '&' (key 'monospace-font-name' from schema 'org.gnome.desktop.interface'). This call will probably stop working with a future version of glib.
Package libgl1-mesa-dri:i386 needs to be installed
Package libgl1-mesa-glx:i386 needs to be installed
Package libc6:i386 needs to be installed
Running Steam on ubuntu 14.04 64-bit
STEAM_RUNTIME is enabled automatically
Error: You are missing the following 32-bit libraries, and Steam may not run:
libGL.so.1
Installing breakpad exception handler for appid(steam)/version(1457470346)
Installing breakpad exception handler for appid(steam)/version(1457470346)
[2016-03-09 21:24:04] Startup - updater built Mar  8 2016 11:30:41
[2016-03-09 21:24:04] Verifying installation...
[2016-03-09 21:24:04] Verification complete
[2016-03-09 21:24:10] Shutdown
  • In order to get some information so that people can help, try opening a terminal window and typing steam. The output will be helpful to know. – Organic Marble Mar 10 '16 at 0:39
  • Try installing the missing packages. – Organic Marble Mar 11 '16 at 12:23
  • How would I do that? Sorry, I'm pretty new to Linux. – Quinn Mar 12 '16 at 2:16
  • To install a package you open a terminal window and type sudo apt-get install [packagename] However, since these packages didn't get installed automatically, there are probably dependency problems, and you may get into a mess if you try. I'd suggest searching this site for similar problems, I'm pretty sure I've seen things like this before. – Organic Marble Mar 12 '16 at 3:10
  • For example, this: askubuntu.com/questions/588024/… – Organic Marble Mar 12 '16 at 3:11
0

There is no automatic way to do this. There are two ways to go about it.

  1. Long Way (safe): Go through and run sudo apt install [package name] with all known packages. It will tell you in the errors what others are needed. Add those to your list and keep trying until all dependencies are satisfied. This works correctly almost every time (I have had to do this around 45-55 times. It has never failed), but expect it to take 30 minutes to an hour and a half.
  2. Fast Way (may fail to a degree): Run sudo apt-get -f install [package name] with one package at a time. (i.e. sudo apt-get -f install libgl1-mesa-dri:i386) That will force dependencies to install, but you sometimes get a slight error with Steam accepting the packages, depending on your release. 15.04 almost always fails in this way, but 14.04 LTS generally accepts them.

    If steam doesn't accept them, you have to launch steam with a script. Do this to make the script:

    1. In terminal, type: cd Desktop && gedit launch_steam.sh && sudo chmod +X launch_steam.sh
    2. When the text editor opens, insert this:

      #!/bin/bash
      export LD_PRELOAD='/usr/$LIB/libstdc++.so.6'
      export DISPLAY=:0
      steam &
      

      Make sure your whitespace is correct.

While this does work for opening the launcher, it often won't work for the individual games. If it doesn't, sorry, you are kind of out of luck if you don't want to create that script for each game. (replace steam with the command to run the game).

Explanation: the first two commands create a shell script file on your desktop and the last one allows you to run it. The script allows you to force steam to use the proper drivers. The ampersand makes steam run in background (just its processes, don't worry, the window will still appear), rather than just open then stop.
If you made the script, you will have to open steam by typing this in the terminal ./Desktop/launch_steam.sh.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.