5

I have tried both Cheese and guvcview. The vids play back fine in the recording apps themselves, but when I load them up in VLC, OpenShot, or Cinelerra, all I get is the initial frame (frozen) and the audio track.

I have tried both .mkv and .avi formats in guvcview (Cheese only allows .mkv), and I get the same result every time. I have also tried converting to .mp4 - When I do this, I get no picture at all, and only audio.

My laptop is an HP dv7 4285-dx, and the webcam I'm using is the built-in HP TrueVision located in the center above the screen. I'm running kernel 4.2.0-25-generic x86_64.

Another problem I'm having is that this webcam should be able to go above 640 x 480 resolution, but I can't seem to find the option in any of the recording apps, nor can I find the proprietary drivers anywhere online.

If you need more info, comment and I will provide to the best of my ability. Any help would be much appreciated. Thanks!

EDIT: Here is one of the files (.avi), which is doing the same thing.

http://www.datafilehost.com/d/0bd39092

Thanks again for any help.

  • Could you upload one of the created videos (that don't play on vlc) here: datafilehost.com . Interesting to see if the files themselves are unusual in any way... – andrew.46 Mar 11 '16 at 22:54
  • Done. datafilehost.com/d/0bd39092 – Adam Hayes Mar 16 '16 at 10:00
  • Thanks for that. FFprobe reports a problem with that file: 'scale/rate is 1000/0 which is invalid. (This file has been generated by broken software.)' and the video does not play on my system, audio is fine. A few thoughts: 1. Small update available from the developer's PPA: launchpad.net/~pj-assis/+archive/ubuntu/ppa 2. Have a look at the file ~/.config/guvciew to alter video resolution, fps and others. 3. I believe guvcview uses FFmpeg for output video so it might be worth your while to use a more modern FFmpeg, I cannot test this at the moment as my own webcam is dead :( – andrew.46 Mar 16 '16 at 12:22
0

Open a terminal and type:

sudo apt-get update && sudo apt-get upgrade

Open Synaptic package mananger from Mate menu and search for ubuntu-drivers-common & software-properties-gtk and make sure that both are installed if not just right click on it and choose Mark for installation and Apply.

Now open the Mate menu then look for Additional Drivers then choose the proprietary driver for your graphics card, if is marked as tested enable that. Now reboot.

If you cant find the Additional Drivers for Mate menu just type in a terminal:

/usr/bin/software-properties-gtk --open-tab=4

OR

software-properties-gtk --open-tab=4

OR

software-properties-gtk

I never used the Mate distro in the past.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.