4

I have installed mysql, mysql-server, apache2 and many more. May be I have installed some wrong PPA or programs which cause this problem. Basically, I need to run local server (eg. for wordpress). So I need to localhost/phpmyadmin. Somehow localhost is working (it shows it's default page) but localhost/phpmyadmin not working.

When I tried to sudo apt-get install phpmyadmin, It gives following output

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:

phpmyadmin : Depends: libapache2-mod-php5 but it is not going to be installed or
                       libapache2-mod-php5filter but it is not going to be installed or
                       php5-cgi but it is not going to be installed or
                       php5-fpm but it is not going to be installed or
                       php5 but it is not going to be installed
              Depends: php5-mysql but it is not going to be installed or
                       php5-mysqli but it is not installable or
                       php5-mysqlnd but it is not going to be installed
              Depends: php-gettext but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

When I tried sudo apt-get install php5 libapache2-mod-php5 , It gives following error

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libapache2-mod-php5 : Depends: php5-common (= 5.5.9+dfsg-1ubuntu4.5) but 5.5.9+dfsg-1ubuntu4.14 is to be installed
                       Recommends: php5-cli but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Again, I tried to install missing phps-common by sudo apt-get install php5-commom, It shows php5-common is already it's newest version. Here is the output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libapache2-mod-php5 : Depends: php5-common (= 5.5.9+dfsg-1ubuntu4.5) but 5.5.9+dfsg-1ubuntu4.14 is to be installed
                       Recommends: php5-cli but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
maddy@maddy-PC:/$ sudo apt-get install php5-common
Reading package lists... Done
Building dependency tree       
Reading state information... Done
php5-common is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 5 not upgraded.

So, guys I need your help to install phpmyadmin.

UPDATE Here is an output of grep -R --include '*.list' '^deb ' /etc/apt

/etc/apt/sources.list:deb cdrom:[Ubuntu 14.04.3 LTS _Trusty Tahr_ - Beta amd64 (20150805)]/ trusty main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-updates main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty universe
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-updates universe
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty multiverse
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-updates multiverse
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-backports main restricted universe multiverse
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-security main restricted
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-security universe
/etc/apt/sources.list:deb http://ubuntu.excellmedia.net/archive/ trusty-security multiverse
/etc/apt/sources.list:deb http://extras.ubuntu.com/ubuntu trusty main
/etc/apt/sources.list:deb http://deb.torproject.org/torproject.org trusty main
/etc/apt/sources.list.d/upubuntu-com-office-trusty.list:deb http://ppa.launchpad.net/upubuntu-com/office/ubuntu trusty main
/etc/apt/sources.list.d/google.list:deb http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/webupd8team-sublime-text-3-trusty.list:deb http://ppa.launchpad.net/webupd8team/sublime-text-3/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-java-trusty.list:deb http://ppa.launchpad.net/webupd8team/java/ubuntu trusty main
/etc/apt/sources.list.d/google-chrome.list:deb http://dl.google.com/linux/chrome/deb/ stable main
/etc/apt/sources.list.d/cordova-ubuntu-ppa-trusty.list:deb http://ppa.launchpad.net/cordova-ubuntu/ppa/ubuntu trusty main
/etc/apt/sources.list.d/webupd8team-tor-browser-trusty.list:deb http://ppa.launchpad.net/webupd8team/tor-browser/ubuntu trusty main
/etc/apt/sources.list.d/nodesource.list:deb https://deb.nodesource.com/node_5.x trusty main
/etc/apt/sources.list.d/ubuntu-wine-ppa-trusty.list:deb http://ppa.launchpad.net/ubuntu-wine/ppa/ubuntu trusty main

and output of apt-cache policy php5-common

php5-common:
  Installed: 5.5.9+dfsg-1ubuntu4.14
  Candidate: 5.5.9+dfsg-1ubuntu4.14
  Version table:
 *** 5.5.9+dfsg-1ubuntu4.14 0
        100 /var/lib/dpkg/status
     5.5.9+dfsg-1ubuntu4.5 0
        500 http://ubuntu.excellmedia.net/archive/ trusty-updates/main amd64 Packages
        500 http://ubuntu.excellmedia.net/archive/ trusty-security/main amd64 Packages
     5.5.9+dfsg-1ubuntu4 0
        500 http://ubuntu.excellmedia.net/archive/ trusty/main amd64 Packages

UPDATE 2 Here is an output of aptitude search '?narrow(?installed, !?version(CANDIDATE))'

W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main amd64 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-amd64_Packages)
W: Duplicate sources.list entry http://dl.google.com/linux/chrome/deb/ stable/main i386 Packages (/var/lib/apt/lists/dl.google.com_linux_chrome_deb_dists_stable_main_binary-i386_Packages)
W: You may want to update the package lists to correct these missing files
i   google-chrome-stable            - The web browser from Google               
i   nodejs                          - Node.js event-based server-side javascript
i   oracle-java8-installer          - Oracle Java(TM) Development Kit (JDK) 8   
i   oracle-java8-set-default        - Set Oracle JDK 8 as default Java          
i   tor-browser                     - Tor Browser Bundle                        
  • Which Ubuntu version are you using? 14.04/15.10? – blade19899 Mar 10 '16 at 8:04
  • @blade19899 14.04 LTS – Madan Bhandari Mar 10 '16 at 8:04
  • try: sudo apt-get -f install! – blade19899 Mar 10 '16 at 8:05
  • @blade19899 it gives same problem – Madan Bhandari Mar 10 '16 at 8:07
  • Please edit your question and give me the outputs of grep -R --include '*.list' '^deb ' /etc/apt and apt-cache policy php5-common, then we can solve it. – Byte Commander Mar 10 '16 at 8:22
1

Your installed version of php5-common is incompatible with the packages you want to install.

The reason is very likely a PPA you have added, then installed a newer version of php5-common (and maybe other packages) from it and removed or disabled the PPA again.

What we must do now is to remove those "too new" versions from your package cache to prevent another accidental reinstallation of them, and then downgrade the php5-common package to the version available from the official repository:

sudo apt-get clean    
sudo apt-get install php5-common=5.5.9+dfsg-1ubuntu4.5

Only if that did not work yet, run the commands below afterwards. The last one is the same as above.

sudo rm -rf /var/lib/apt/lists
sudo apt-get update
sudo apt-get install php5-common=5.5.9+dfsg-1ubuntu4.5

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.