0

I am having screen display problem on my ubuntu 14.04 LTS OS with I dual boot with Windows 10 recently. The display is "incomplete" or "flaky" at all time even at log in page (example in the picture below):

a screenshot

The missing part keep changing whenever I move my cursor over or highlight them. The situation gets worse when I am running something heavy, installing a software for example.

I am not really sure about the problem but my guess was I have to install Nvidia graphic driver manually. The graphic card in my PC is Nvidia GeForce GTX 745. I tried installing the driver through:

  1. Driver taken from Nvidia website

  2. sudo apt-get install nvidia-current

  3. sudo apt-get install nvidia-current-updates

However, all three methods seem not accepted by my OS where I couldn't even log in after reboot. I have to use Ctrl + Alt + F1 to log in and uninstall them.

Thanks for your time and your helps are very much appreciated.

-Leow-

0

I have always had great luck with Nvidia devices using the GUI tools.

System Settings > Software & Updates (at the bottom, centre) > Additional Software (farthest right tab)

The tab takes a minute to load while it runs some repository check, and will provide the option to install various available versions suitable for your graphics hardware and also your cpu. However, on an old AMD apu notebook, installing the proprietary drivers for the cpu & gpu messed up the system that was enough of a pain that I ended up reinstalling (didn't have anything important on it), and everything mostly works pretty well most of the time using only the default open source drivers. On my Intel & Nvidia hardware the proprietary drivers have almost always worked perfectly. I stick with the drivers labelled "proprietary, tested" rather than the stream with updates, which has caused me some small problems occasionally.

1
  • Hi Andrew my life saver! It works! Somehow I have never thought of GUI tools when it comes to Linux (bad perception). However, after installing the driver labelled as "proprietary, tested", it popped out window saying “The system is running in low-graphics mode" (as in askubuntu.com/questions/141606/…) and the screen keep flashing. I enter console mode (ctrl+alt+F1) to reboot, after that everything just works perfectly until now. Will see what will happen after this. Thanks so much. – Leow Mar 9 '16 at 8:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.