1

I'm interested in making sure that /dev/vhost-net is read/writable by group vhost-net. I do this using chown + chmod. However, after every reboot (and in fact after every reset of the device), it resets back to root/root. I tried adding a udev rule:

> cat /etc/udev/rules.d/40-permissions.rules

KERNEL=="vhost-net", GROUP="vhost-net", MODE="0660"

This doesn't appear to have any effect. How can I make this permission change permanent?

1

I ran into the same problem and I think I figured it out. It seems to me the /dev/vhost-net file may be present, even if the vhost-net kernel module is not loaded.

When I create the udev rule (same as yours) and (re)load the module by executing rmmod vhost-net && modprobe vhost-net the configuration is picked up just fine.

To make it persistent I added vhost-net to the /etc/modules-load.d/modules.conf.

1
  • Same problem on Ubuntu 16.04.4. This solved the problem, thanks. – cyfdecyf Jun 25 '18 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.