0

I can't install ubuntu 15.10 at MSI GL62 6QD. Any options (install or try without install), as checking this disk makes the laptop freeze after two lines of Nouveau driver are shown.

I've checked the iso and it is fine (coincidence of md5).

I've also disabled every advanced option at BIOS configuration, and it freezes at the same time always.

The laptop is provided with a 950M Nvidia chipset.

Is there any possible solution?

Edit: I've also tried to install Xubuntu 15.10, which shows this output:

enter image description here

Edit 2: I've installed Linux Mint Rosa with Cinamon which is based in Ubuntu 14.04, but I'm still interested in Ubuntu 15.10.

3
  • what is your dedicated graphics card?
    – Ashu
    Commented Mar 8, 2016 at 17:30
  • @Ashu Edited with graphics card info.
    – lilezek
    Commented Mar 8, 2016 at 18:57
  • @lilezek can you please share yout steps you followed, I am trying to do the same but no luck so far.
    – user518617
    Commented Mar 14, 2016 at 15:57

3 Answers 3

1

I am referring to this answer from my other answers. I had a login loop issue as mentioned here. It seems you are also encountering login loop issue due to nvidia drivers issue.

First uninstall the currently installed NVIDIA drivers.Boot the computer, when the GRUB menu appears ...

Highlight the Ubuntu menu entry and press the E key.Add nouveau.modeset=0 to the end of the linux line. Press F10 to boot the Ubuntu operating system.

When the login screen appears press Ctrl + Alt + F1. Enter your user name and the password, then execute :

sudo apt-get purge nvidia*  
sudo reboot 

Now install the latest official stable NVIDIA drivers.Boot the computer, when the GRUB menu appears ...

Highlight the Ubuntu menu entry and press the E key.Add nouveau.modeset=0 to the end of the linux line. Press F10 to boot the Ubuntu operating system.

When the login screen appears press Ctrl + Alt + F1. Enter your user name and the password, then execute :

sudo add-apt-repository ppa:graphics-drivers/ppa 
sudo apt-get update
sudo apt-get install nvidia-361 sudo reboot

Note : Maybe it is explicitly necessary to select the NVIDIA adapter in BIOS.

In case you have installed the nvidia driver from their site then uninstall it as per that instructions.Uninstall that driver by running, as root, sh ./NVIDIA-Linux-x86_64-361.28.run and follow the on screen instructions.

Note : The solution I have provide has been tested on Ubuntu 14.04 LTS and Ubuntu 15.10 for two GPUs

5
  • I can't install Ubuntu. How do I disable Nouveau then?
    – lilezek
    Commented Mar 8, 2016 at 20:36
  • 3
    Do the same from the install menu, then run the commands after install. start from Add nouveau.modeset=0 (you can do this on the install boot menu), install and then follow his tutorial.
    – Izzno
    Commented Mar 9, 2016 at 22:53
  • But how do I uninstall Nouveau controllers from Ubuntu if it is not installed yet? It's burnt in a DVD. Should I use USB installation instead? If so, could @Ashu rewrite the answer to follow all these considerations?
    – lilezek
    Commented Mar 10, 2016 at 12:18
  • 1
    @lilezek. Please do what IzznogooooD mentioned. You can do this at the time of install also.
    – Ashu
    Commented Mar 10, 2016 at 14:04
  • @lilezek. glad it worked out for you.
    – Ashu
    Commented Mar 10, 2016 at 22:22
0

I have just installed ubuntu on my MSI GP62 6QE Leopard Pro (Which also has the NVIDIA 950M) few days back succesfully. You may try by adding boot line parameter as, nouveau.modeset = 0

You may check the reference as well, Boot Option : ACPI=off

-1

Got the same problem on my lenovo y700 ideapad. I needed a distro with a newer kernelversion so i tried the new ubuntu 16.04 lts you can find the daily build and newest version here http://cdimage.ubuntu.com/daily-live/current/

Give it a try ! :)

5
  • Lets give a try.
    – lilezek
    Commented Mar 8, 2016 at 18:58
  • Not working. Nothing changes between 16.04 and 15.10.
    – lilezek
    Commented Mar 8, 2016 at 19:23
  • Okey. Is your computer a "new" PC so you have UEFI instead of the old typ BIOS ? Then you need to deactivate UEFI and activate leagecy mode in BIOS instead and deactivate quick boot and secure boot also in BIOS :)
    – Hyltixa
    Commented Mar 8, 2016 at 19:26
  • I've tried with both legacy and uefi, and with both fast and secure boot always disabled.
    – lilezek
    Commented Mar 8, 2016 at 20:39
  • 1
    I wouldn't recommend deactivating UEFI, im running 16.04 and booting UEFI only.
    – Izzno
    Commented Mar 9, 2016 at 22:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .