Every time I want to enable my webcam or microphone in my browser, the regular flash screen pops up and I need click allow or deny.

However I can not click allow or deny, it is not responding to my clicks.

Does anyone know a fix ?


6 Answers 6


access http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager07.html

  1. select link
  2. click never ask again
  • 11
    This has no effect. Dec 4, 2011 at 9:30
  • 2
    The above worked for me. You can also run flash-player-properties on Dash by typing in "Adobe". Then go to the website you want to allow Cam/Mic access. Set it to Allow. Make sure you click on the Camera & Mic Access column of the site, and not the name of the website so the drop-down options will show because the layout looks just like a text list that's unclickable.
    – Marky
    Feb 20, 2012 at 15:48
  • 3
    Clicking never ask again sets the available storage to 0. I don't know why it's called never ask again it's more like disable storage.
    – tutuca
    Apr 14, 2012 at 2:40
  • 1
    Those who's having trouble. There's 7 tabs that you can choose under the settings. So: choose "Website Privacy Settings" which is the third from the right (picture of an eye on a monitor). Choose which web that you want to allow in the list and select "Always Allow". It works when i'm trying to let tunerr.com to access my microphone.
    – AFwcxx
    Jul 5, 2013 at 9:17
  • 3
    +1 for a helpful workaround, but it would be nice to have a way to actually click the box when it comes up.
    – 6005
    Apr 1, 2014 at 16:34

When you surf to Settings Manager - Website Privacy Settings, which will bring you to the tab with the monitor with the eye on, you need to do the following:

  1. Find the site in the list and click on it..

  2. Click on Always allow.

  3. Go back to the site and refresh the page, the dialog will pop up again but this time you are able to click on the Allow button.

Tried and got it to work this way.

  • I have the same problem as the OP, this doesn't help b/c it doesn't allow me to click on allow in the given link Jan 31, 2014 at 17:25
  • Had the same issue as @tofu_bacon, magically fixed it by setting global storage configuration to 10MB then deleting all from the per site storage configuration
    – xvan
    Sep 29, 2016 at 5:43

I think this is related to a problem others are having about not being able to interact with the flash player settings window, sometimes not at all and sometimes only in fullscreen.

For me, the culprit was Adblock Plus in both Chromium and Firefox. When wanting to work with a YouTube video, I disabled Adblock Plus on youtube.com, and so forth.

  • it's the flashblock addon. if you add both the domain where the embed tag is in (the one in your address bar while viewing the flash) and the domain that the option screen is asking access for, it will work. but you still have the bug where you can't interact with the settings screen, but now the camera access will be allowed always. not exactly a fix...
    – gcb
    Feb 16, 2013 at 19:12
  • For me, it was necessary to uncheck ABP's "Show tabs on Flash and Java" option.
    – anol
    Aug 11, 2014 at 12:31

Hey guys I was having the exact same problem until I wrote on the adress bar chrome://plugins and then I clicked in more details located at the top right and I disabled the adobe flash player plugin and enabled the PepperFlash one but I'm using google chrome so this will only work for google chrome users.


Occasionally I found another workaround: I clicked inside the flash window, then managed to choose the settings with the «Tab» button, then pressed enter.


Open Firefox, go to Tools, go to Addons. Click on that list Adobe Flash, click dropdown menu and change Always ask to Always start. Now when you on Omegle or other flash based webcam chat etc., your cam WILL IMMEDIATELY open, without asking allow/no. If you don't want that "black screen" see you, just block web cam at start until you are sure you want to share cam to other person. You can also block cam accessa in omegle when needed by a button in camera area.

Not the answer you're looking for? Browse other questions tagged or ask your own question.