0

I downloaded backburner (renderfarm manager) from here . I tried to convert it with sudo alien -cv backburner.rpm but terminal prints out

backburner.rpm is for architecture i386 ; the package cannot be built on this system

Regarding this How do I convert a x86 RPM to a x86 DEB within a x64 system? i did

sudo alien -g backburner.rpm
cd backburner-dir/
sudo nano debian/control  (change i386 to amd64 )
sudo debian/rules binary

and I get following output

dh_testdir
dh_testdir
dh_testroot
dh_prep
dh_installdirs
dh_installdocs
dh_installchangelogs
find . -maxdepth 1 -mindepth 1 -not -name debian -print0 | \
        xargs -0 -r -i cp -a {} debian/backburner.sw.base
dh_compress
dh_makeshlibs
dh_installdeb
dh_shlibdeps
dpkg-shlibdeps: warning: debian/backburner.sw.base/usr/discreet/backburner/cmdjob contains an unresolvable reference to symbol uuid_generate: it's probably a plugin
dpkg-shlibdeps: warning: 2 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: debian/backburner.sw.base/usr/discreet/backburner/backburnerManager contains an unresolvable reference to symbol uuid_parse: it's probably a plugin
dpkg-shlibdeps: warning: 2 other similar warnings have been skipped (use -v to see them all)
dpkg-shlibdeps: warning: package could avoid a useless dependency if debian/backburner.sw.base/usr/discreet/backburner/cmdjob debian/backburner.sw.base/usr/discreet/backburner/backburnerServer debian/backburner.sw.base/usr/discreet/lib32/backburner/2015.0/libDLnrapi.so debian/backburner.sw.base/usr/discreet/backburner/backburnerManager were not linked against libuuid.so.1 (they use none of the library's symbols)
dh_gencontrol
dh_md5sums
dh_builddeb
dpkg-deb: building package `backburner.sw.base' in `../backburner.sw.base_2015.0.1-1689_amd64.deb'.

Could you guys explain and help me with those warnings ??

I already tried adding libuuid.so.1 (with and without comma )inside debian/control Depends so it looked like

Depends: ${shlibs:Depends} , libuuid.so.1

as muru suggested i did

namei -lx ../backburner.sw.base_2015.0.1-1689_amd64.deb

output

f: backburner.sw.base_2015.0.1-1689_amd64.deb
-rwxrwxr-x render render backburner.sw.base_2015.0.1-1689_amd64.deb

Thanks in advance!

9
  • It's saying that you shouldn't link the software against libuuid since the binaries don't use anything from that library. The dependencies are already correct.
    – muru
    Mar 7, 2016 at 23:56
  • Thanks muru. So what 's right and possible solution to output .deb? I spent whole day for searching and testing without any luck .
    – bolek
    Mar 8, 2016 at 0:02
  • the output says it created a deb file. Look in the parent directory, it should be there.
    – muru
    Mar 8, 2016 at 0:03
  • Yeah it's there but it's kind of broken? ( ln -l - red colored )
    – bolek
    Mar 8, 2016 at 0:05
  • what's the output of namei -lx ../backburner.sw.base_2015.0.1-1689_amd64.deb?
    – muru
    Mar 8, 2016 at 0:08

2 Answers 2

0

At the end I did it with rpm > tgz > deb . But i suppose that what Mohit Rajan suggested could be helpful to. I think now that even alien -g packagename and manual installation - copying of files could work too. Thanks for that.

Anyway would be cool to know how to avoid such warnings and how to deal with them. I just don't want to ignore it without further investigation

0

You can use alien, but I don't suggest that. Alien can change RPM to DEB or DEB to RPM, but it can not make sure the package can be installed without any problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .