2

I am currently running Ubuntu 14.04 an an 2015 DELL XPS (Developer Edition) and dealing with Speed-Issues, stumbled upon some strage behaviour regarding CPU-Speed. It seems, the CPU-frequency is never higher than 1100 MHz. Using "indicator-cpufreq" It shows possibly available speeds up to 2.2 GHz, but I can only choose up to 1.1 GHz. Same with command-line information:

lscpu
Architecture:          x86_64
CPU op-mode(s):        32-bit, 64-bit
Byte Order:            Little Endian
CPU(s):                4
On-line CPU(s) list:   0-3
Thread(s) pro Kern:    2
Kern(e) pro Socket:    2
Socket(s):             1
NUMA-Knoten:           1
Anbieterkennung:       GenuineIntel
Prozessorfamilie:      6
Modell:                61
Stepping:              4
CPU MHz:               1100.000
BogoMIPS:              4389.76
Virtualisierung:       VT-x
L1d Cache:             32K
L1i Cache:             32K
L2 Cache:              256K
L3 Cache:              3072K
NUMA node0 CPU(s):     0-3

cat /proc/cpuinfo |grep MHz

MHz : 1100.000 cpu MHz : 1100.000 cpu MHz : 1100.000 cpu MHz : 1100.000

Any idea what could be wrong? I was waiting for the next LTS. Could an update to 15.04 solve the problem? Thanks :)

  • CPU power autoscales on hardware side when it is needed. Do you ever need that power? – dadexix86 Mar 7 '16 at 20:33
  • Which frequency scaling driver are you using? And which governor? cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_driver and cat /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor. And as previous comment asked, does the CPU frequency go up if you load down the CPUs? – Doug Smythies Mar 7 '16 at 20:50
  • @DougSmythies scaling driver is "acpi-cpufreq". governour is "userspace". high cpu-load does nothing to increase frequency. I just tried again to be sure, but no change, even if the load is at 400%. Whats really strange to me is, that i can select all the frequencies in the ui-tool, but just up to 1100MHz – Michael Dörsam Mar 7 '16 at 21:42
  • Try the ondemand and/or the performance governors. What do you get with them? as su ( sudo su ) do: for file in /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor; do echo "ondemand" > $file; done – Doug Smythies Mar 7 '16 at 22:10
  • unfortunately no change: "ondemand" the cpu is between 500-1100MHz while its 1100Mhz in "performance". Again while running CPU-intense programs – Michael Dörsam Mar 7 '16 at 22:21
0

I had the same problem, but I remembered having set up silent_mode/eco_mode in dualboot Windows which had been hibernated before booting Ubuntu. Rebooted to Windows, turned off silent_mode/eco_mode, rebooted to Ubuntu -- 2.7GHz again.

May be a coincidence, but just rebooting with external power plugged in helped.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.