2

Something has changed recently, and I can't figure out what.

I have a headless server running Ubuntu 12.04 Server with Samba and CUPS and several shared drives (frankenstein).

Everything worked fine up until today (or at least today is when I noticed it).

I added a second USB hard drive to frankenstein, and rebooted the server to check that it automatically mounted, which it did. I can browse both of the two USB drives I have attached no problem. All of this was done via ssh from my laptop (roamer). I did not (yet) edit smb.conf to add any shares from the new drive.

I opened PCManFM on roamer (Lubuntu 14.04), and it is not seeing any other computers on the network (two Windows boxes and frankenstein). Since it's not seeing anything, I don't think the problem is caused by anything I did to frankenstein. I could see all the computers on the network in the past.

I can access network shares on frankenstein from both of the two Windows boxes. I can also access the CUPS server on frankenstein via HTTP from roamer as well as ssh into frankenstein, so they can talk to each other. The problem seems to be solely with PCManFM.

Ideas?

Ok, so editing to add some additional information I just figured out. If I type smb://frankenstein/working into the address bar in PCManFM, I can access the share ("working" is one of the Samba shares). I tried this with a couple more, and they all work.

That solves the most important part of the problem for me, but I still don't know why I can no longer browse to these shares via the Go/Network menu.

  • PCmanFM is a dead project. Have you tried out the newer version called SpaceFM? Much better at handing mounted volumes and has way better features. – Kalamalka Kid Mar 7 '16 at 8:38
  • Not sure if you can call PCManFM a dead project since a new version was released in February of this year. – Rex Mar 7 '16 at 16:43
  • I'll look at Space FM, but I'm still troubled by what changed. I hate "it worked before, but won't work now" problems because it means that something has changed. It's a puzzle the bothers my brain ... – Puckster Mar 13 '16 at 23:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.