3

Today I tried Ubuntu on my laptop Asus n550jx 64 bit version. Everything works fine except there is constant static/ hissing in headphones (in laptop speaker too, but its too silent to be heard). It uses intel 4th generation sound drivers or something liek that, on windows realtek hd drivers. Also hissing is constant - it doesn't stop if there is no music playing or something like, pop only happens when Ubuntu boots. Hissing doesn't become louder if there max volume, it happens even if there is speaker on mute( sound of hissing changes thought).

What have tried:

  • Mute built in microphone- no effect
  • Check playback settings with alsamixer. There was something loopback which turned off made hissing quieter, but its still annoying
  • Checked sound card power saving which was turned off

So its something like that...

Oh and there is no hissing on windows 10.

3

The following solved it for my ux501VW laptop

sudo apt-get install alsa-tools-gui
sudo hdajackretask
  1. Select both Show unconnected pins and Advanced override in the Options
  2. Override Pin ID 0x16 Changing Device to: headphones
  3. Click the Install boot override button
  4. Reboot
  • This worked for me on Dell XPS 13 9350. I had to change pin 0x12 (internal mic) to disabled. Finally I have peace. – fastenedrex Aug 6 '17 at 17:40
3

I know I am late to the party but I solved this on Ubuntu 17.04 by doing the following:

Open terminal and type the following:

alsamixer

and then press F6 and select your sound card. Use your arrow keys to decrease the volume where the hissing sound disappears (I solved it by decreasing it to green area only. See the screenshot). After that, adjust volume using standard volume control on Ubuntu (from Unity menu). You may have to do this every time you plug/unplug sound card but it has given me peace of mind really.

Hope it helps someone.

  • After all these time I have spent looking for a solution this was the fix for me! – dojuba Sep 26 at 20:18
-1

This worked for me http://xps13-9333.appspot.com/#background_noise .
I could not make it run on boot, but its something.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.