I have a fresh Ubuntu 16.04 install on a new laptop (less than a month old) and I'm having a hard time with my keyboard.

It seems like the Ctrl key thinks it's being pressed when it's not. Some examples:

  1. On Chrome, when I scroll up or down with the mouse the zoom suddenly changes, the same happens in Sublime Text.
  2. When typing d on a terminal it suddenly closes the current tab.

The above examples happened at random intervals.

Sometimes, when I actually want to use the Ctrl key and press it to delete a word on the terminal (using Ctrl+w) it only works the first or second time, then it suddenly stops working (while holding down the Ctrl).

It's not just the Ctrl key because sometimes happens with the Alt key too.

What I have tried:

  • Deleting the .config, .gconf, .gnome and .gnome2 folders as suggested in a post I found
  • Changing the Keyboard Layout
  • On my keyboard settings, the "Key presses repeat when key is held down" is checked
  • The "Sticky keys" option is off.

My laptop:

  • HP Pavilion
  • AMD A8-7410 APU with AMD Radeon R5 Graphics
  • 12 GB RAM
  • 1 TB HDD
  • Ubuntu Mate 16.04

Extra info:

  • I'm using gnome-session-fallback as my DE.
  • I'm using fglrx driver as an alternative to X.org


  • It's happening with the Shift keys too
  • It's happening with both the left and right Ctrl, Shift, etc. keys so I guess we can discard hardware failures as suggested by @whtyger in the comments
  • 1
    Can it be a physical malfunction of the key on the keyboard (that's my wild guess)? This can be checked by booting your system from LiveCD.
    – whtyger
    Mar 7, 2016 at 19:53
  • Thanks @whtyger, I don't have a Live CD right now, but it's happening with both Ctrl keys, do you think both can be physically wrong? what are the chances of that happening?
    – César
    Mar 7, 2016 at 23:43
  • H'm, if both of them behave so, than the chances are pretty thin.
    – whtyger
    Mar 8, 2016 at 5:50
  • 2
    Have you tried the showkey command? (may need using from the <ALT-F1> console, not X) This may shed some further light on what's going on? Mar 8, 2016 at 19:20
  • 1
    @dadexix86 please refer to the Launchpad bug I think they have found a temporary solution
    – César
    Apr 28, 2016 at 16:12

5 Answers 5


Ok, so after some time of testing and with the help of @Dea1993 and the guys on the Launchpad bug thread. This is how I fix it.

  1. Edit the line GRUB_CMDLINE_LINUX_DEFAULT on /etc/default/grub to:

    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.dumbkbd=1"
  2. Update grub:

    $ sudo update-grub
  3. Reboot

Although this causes the CAPS LOCK keyboard led not to blink (but this is, in fact, the expected behavior).

For the record, these are the options I found regarding the i8042 controller:

  • i8042.direct - Put keyboard port into non-translated mode
  • i8042.dumbkbd - Pretend that controller can only read data from keyboard and cannot control its state (Don't attempt to blink the leds)
  • i8042.noaux - Don't check for auxiliary (== mouse) port
  • i8042.nokbd - Don't check/create keyboard port
  • i8042.noloop - Disable the AUX Loopback command while probing for the AUX port
  • i8042.nomux - Don't check presence of an active multiplexing controller
  • i8042.nopnp - Don't use ACPIPnP / PnPBIOS to discover KBD/AUX controllers
  • i8042.reset - Reset the controller during init and cleanup
  • i8042.unlock - Unlock (ignore) the keylock

I've the same problem on HP Pavilion 15 ab062nl. CPU AMD A10 8700p, GPU radeon r6 + radeon r7 m360, RAM: 8GB DDR3.

Try pressing only Left_SHIFT Key. On my notebook this fixes the problem for a while

problem with SHIFT, CTRL and ALT button with integrated keyboard

I've also opened a bug on launchpad

You can add yourself as affected or create a new bug if you think yours is different.

In my opinion it's a problem of compatibility with these HP Keyboards.

  • Could you please consider giving me the solution as stated on the launchpad bug? Thank you :)
    – César
    Apr 28, 2016 at 16:05

i've finally solved the problem updating BIOS

  • Hey Man! Could you share the way you did that? Thanks! I'm still having some issues using the dumb keyboard, sometimes the system hangs.
    – César
    Oct 13, 2017 at 23:54
  • i've download from HP site (search your specific model) support.hp.com/it-it/drivers then i'ìve installed the new version of bios under windows 10 (the installer is a .exe)
    – Dea1993
    Oct 15, 2017 at 7:19

Does it happen with Unity as the DE?

Do you have a wireless mouse plugged in that is sending phantom signals to take over your computer? I had a similar experience, and it turned out my mouse button was being held down in my bag. Like you said, it was like some strange Sticky Keys situation. When I unplugged the wireless mouse dongle the problem went away.

  • 1
    This was exactly my problem. Unplugging and pluggin in my wireless mouse dongle solved the problem Jul 27, 2020 at 13:45
  • This was a lifesaver! Even a restart hadn't helped. It was driving me crazy! Thanks a ton! +50 bounty to you! Nov 10, 2020 at 2:22

Are you using any remote control software like teamviewer? It may be that the states of the control keys are not handled proper when switching back form a remote controlled session.

  • No. I'm not using anything like it
    – César
    Mar 18, 2016 at 16:13

Not the answer you're looking for? Browse other questions tagged or ask your own question.