This question already has an answer here:

Today when i opened Chrome i was greeted with this message:

enter image description here

I logged in, and reopened Chrome, still the same error appeared.

I removed the folder Web Data in hopes that it would fix it, still nothing. I thought maybe there were some update, so i tried sudo apt-get update and got this:

W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release
Unable to find expected entry 'main/binary-i386/Packages' in
Release file (Wrong sources.list entry or malformed file)

I reinstalled Chrome, and still this error was here.

Could this be because i keep getting the message :

This Computer will no longer recieve Google Chrome updates because this Linux system is no longer supported.

Also it keeps freezing on me so i need to Ctrl+Alt+F2 then Ctrl+Alt+F7. The freezes are not constant, but enough to annoy a person.

Can i somehow fix these errors, or do i need to move to Chromium?

I should note that i am using Ubuntu 12.04 64-bit version.

marked as duplicate by David Foerster, muru, Braiam, Community Mar 7 '16 at 11:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Somehow, this on the Hot Network Questions. – cat Mar 6 '16 at 17:53


32-Bit Chrome builds have been discontinued.


32-bit system

Replace google-chrome with chromium-browser:

# aptitude purge google-chrome-stable
# aptitude install chromium-browser

(as root, indicated by # as opposed to $) or

$ sudo aptitude purge google-chrome-stable
$ sudo aptitude install chromium-browser

64-bit system

# sed -i -e 's/deb http/deb [arch=amd64] http/' /etc/apt/sources.list.d/google-chrome.list /opt/google/chrome/cron/google-chrome
# aptitude update && aptitude upgrade


$ sudo sed -i -e 's/deb http/deb [arch=amd64] http/' /etc/apt/sources.list.d/google-chrome.list /opt/google/chrome/cron/google-chrome
$ sudo aptitude update && sudo aptitude upgrade


Your Ubuntu is 4 years old. An upgrade might fix at least some of your problems.

  • Thank you for your generous answer. I would gladly upgrade to 14.04, but for some reason, after i install my NVIDIA Driver, it just wont boot anymore, and i'm forced to reinstall. Maybe i'll try Mind or Fedora. – Nikola Atanasov Mar 6 '16 at 17:12
  • @Xy. That's something you could ask about here on AU. – cat Mar 6 '16 at 17:59
  • 1
    Yes i know, and i probably will next time i'm reinstalling linux, because now i have Windows 10 as dual boot and i need it atm. Or as i've said i wanted to try Mint so maybe i'll try that next time. – Nikola Atanasov Mar 6 '16 at 18:07
  • 2
    Ubuntu 12.04 is still supported till April '17. – Pilot6 Mar 6 '16 at 18:30

Google does not support Ubuntu 12.04 with Chrome.

Chromium is not supported either. It can be installed, but an old version, that does not get updates.

You can use Firefox on Ububnu 12.04, or upgrade to Ubuntu 14.04.

  • Why are you answering instead of voting to close? The duplicate already says what you said here... – Braiam Mar 6 '16 at 22:17
  • 1
    It's not exarly same. The new is that Chrome does not support 64-bit 12.04. – Pilot6 Mar 7 '16 at 6:12

Not the answer you're looking for? Browse other questions tagged or ask your own question.