21

I installed Windows 10 on a virtual machine, and everything is working fine. But when I go into fullscreen mode, the size doesn't change, and I get a black screen around the display. Some people suggested that I install the guest additions, so I did. I downloaded the file and inserted it. This did not change anything. I still get a black screen around the VM. How can I fix this?

  • Why did I get a -1? I am willing to improve the question if necessary. – Rahul Mukherji Mar 6 '16 at 12:31
  • This appears to be a Windows issue based on the subject being a Windows VM and not Ubuntu. This is offtopic. (Likely why you got a down vote). – Thomas Ward Mar 8 '16 at 2:20
  • @ThomasWard It is a Windows based issue, that presents as an Ubuntu issue, which is why it is an appropriate question. – Malcolm Anderson Jul 19 '19 at 12:15
  • @ThomasWard (Actually I think it's a VirtualBox question which may or may not be a Windows question.) Downgrading a question without an explanation may not be required, but it adds to the perception that Stack Overflow is an unwelcoming or hostile place. (Personally I think it's a form of bullying) It's not helpful to someone trying to learn. If the down vote had come with a note: "This is a virtualbox issue, and has been answered here ..." it would be helpful. This article is spot on - stackoverflow.blog/2018/04/26/… – Malcolm Anderson Jul 19 '19 at 12:27
20

The guest additions cd needs installed within the client. You can do this from the client toolbar. Devices -> Insert guest additions CD image...

That will mount the guest additions cd image. Click on it to run it. Let it install. It will then reboot the guest operating system. When the guest restarts and you log back in you will be able to go full screen and the resolution will adjust automatically. You can scale the window whatever way you want by dragging the corners of guest window and it will auto adjust to whatever that resolution is.

| improve this answer | |
  • 1
    This answer deserves the most votes. After following these steps, Windows will always fill the entire window without needing to modify settings in either the guest or the host. – trebormf Nov 28 '17 at 21:24
  • Totally agree with @trebormf. This is the correct answer – MrPaulDriver Jan 3 '18 at 9:58
  • At first I found the display to appear slightly 'soft'. After checking the vm display settings I notice that the scale value was 101%. After correcting this to 100% I now have a good sharp display – MrPaulDriver Jan 3 '18 at 10:08
  • 1
    It happened to me after a windows update, when Guest Additions was already installed. Going out of an into full screen mode again (right-ctrl + f, right-ctrl + f) solved the problem (more or less what is in the second paragraph, but without mouse). – Wilbert Aug 13 '18 at 8:25
  • In my case there was no optical drive attached to my VM. I had to go to Settings -> Storage to add one before I could insert the disk – ErikAGriffin Jul 7 at 18:38
4

Most probably the resolution in Virtualbox does not match your monitor resolution. Try to change the resolution inside the virtual machine.

| improve this answer | |
  • How do I achieve this? – Rahul Mukherji Mar 6 '16 at 12:36
  • Inside Windows 10 set the resolution matching your monitor. – kukulo Mar 6 '16 at 12:42
  • Thanks, it worked. Unfortunately, the highest resolution available is 1600x1200. Also, in that resolution, my mouse doesn't go above a certain level. Is there anyway to add a custom resolution? And is there anyway to fix this mouse problem? – Rahul Mukherji Mar 6 '16 at 12:57
  • 5
    I was able to solve the problem. You simply execute this command in the terminal: VBoxManage setextradata "VMName" CustomVideoMode1 1920x1080x32 – Rahul Mukherji Mar 7 '16 at 6:18
  • 1
    @RahulMukherji's answer worked. Just replaced "VMName" with my VM's actual name and after windows booted up, went and selected the 1920x1080 resolution in Windows Display Settings. – Frank Hayward Aug 6 '19 at 9:26
1

you need to install an extension pack which is available at:

https://www.virtualbox.org/wiki/Downloads

| improve this answer | |
1

I had a similar problem and did the following (with the Windows 10 VM stopped):

  1. In the manager right-click and choose settings for the Windows 10 VM
  2. Click on User-Interface options, at the bottom
  3. Un-check/disable the option Show in Full-Screen/Seamless

This seemed too easy to possibly fix it, but it worked for me! No more black anomalies and such!

| improve this answer | |
0

I found there's an option at the bottom right corner of the window.

Screenshot Pick the icon between the folder and recording icon. Choose 'Virtual Screen' in the dropdown then you'll be provided a whole bunch of resizing options. Pick one that fits your testing purposes.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.