7

I tried to burn a DVD with K3B (a data project) but have some problems. K3B does not detect an empty DVD.

I burned a DVD using K3B like 3 days ago, and I did it with success. I don't know what happened, maybe some updates issue?

Anyway, I tried the advice given here: K3b - cdrecord has no permission, but no success, K3B tells me that there's no group like burning (yes, I'm a root).

I tried to burn a DVD with Brasero, and I burned it successfully. However, that does not solve my issue, since I prefer using K3B and simply want to fix it. Any ideas?

$ sudo ls -lah /dev/sr0
brw-rw-rw-+ 1 root cdrom 11, 0 mar  6 12:56 /dev/sr0

$ groups
katie adm cdrom sudo dip plugdev lpadmin sambashare bumblebee
  • 1
    Just to check, have you tried selecting all options except "Use burning group", as mentioned in the comments in post? – whtyger Mar 10 '16 at 7:49
  • 1
    Also you mentioned that "K3B does not detect an empty DVD". Does it produce any error? – whtyger Mar 10 '16 at 7:58
6
+50

Fixing the 'burning group' error:

I can confirm this issue with Ubuntu 14.04 and k3b run as either ordinary user or running with sudo k3b. The solution on my system was to manually create the group from the commandline before opening k3b, demonstrated on my system as follows:

andrew@corinth:~$ sudo addgroup burning
[sudo] password for andrew: 
Adding group `burning' (GID 1001) ...
Done.
andrew@corinth:~$

After this add yourself to the new 'burning' group:

sudo usermod -a -G burning $USER

And then going to the k3b configuration screen:

k3b -->  Settings --> Setup System Permissions

and checking all of the following boxes:

  1. Use burning group: burning (this should work now)
  2. Devices: (Select the device you wish to use)
  3. External Programs: Found Programs (select the applications you wish to use)

Press 'Apply' and all should now be well :).

Further Error Messages?

If however you managed to create the required group but continue to get odd burning problems and errors consider adding Brandon Snider's CDRTools PPA:

sudo add-apt-repository ppa:brandonsnider/cdrtools
sudo apt-get update

And then installing Jörg Schilling's cdrtools and friends (this will safely replace the Debian fork burning tools):

sudo apt-get install cdda2wav cdrecord mkisofs

And finally returning to:

k3b -->  Settings --> Setup System Permissions 

to setup the new applications with the appropriate permissions.

Another few things to try if problems persist:

  1. Try a different brand of disk and if using DVD -R try DVD +R and the reverse.
  2. Experiment with turning Nautilus 'auto-mount' off and on. The k3b FAQs implicate auto-mount in a variety of errors when burning.

Finally here is a screenshot showing the final settings on my own system:

enter image description here

| improve this answer | |
  • Sooo, now I messed up... Did everything you wrote, but after pressing the Apply button, I couldn't burn it. So I did further steps. Now the result is I have nothing in Found Programs section in k3b --> Settings --> Setup System Permissions and I'm getting the message: Can't find cdrdao, cdrecord, growisofs binaries. However, I have them installed :( – Katie – Katie Mar 10 '16 at 20:42
  • Oops! Use the following command to add yourself to the 'burning' group: sudo usermod -a -G burning $USER. I will add this to my answer + screenshot... – andrew.46 Mar 10 '16 at 21:17
  • It didn't help. Now I don't see the message Can't find cdrdao, cdrecord, growisofs binaries and have something like this in my settings: s17.postimg.org/u0qehyuhr/screen11.png but k3b still does not see an empty DVD and says: Please insert an empty DVD drive while it's already inside ... – Katie Mar 13 '16 at 18:27
  • So looks like k3b is now set up perfectly but still no luck :(. Have you experimented with a different dvd type? Although that particular drive will use +R and -R try a different brand and type... Also have a look in Settings -->Configure k3b ... Devices and make sure you have a Write Device enabled. But I confess I am running out of ideas soon :(( – andrew.46 Mar 13 '16 at 18:44
  • Remaining idea comes from the k3b FAqs where auto-mounting can cause a variety of issues: k3b.org/faq. This can be done readily (and reversed as easily) and it would be great if you could do this as a test: askubuntu.com/q/89244/57576 . If this makes a difference I will write it up as part of my answer... – andrew.46 Mar 15 '16 at 4:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.