1

Hi Firstly I'd like to say am a work in progress in windows and a beginner in Linux. Ok now then let me get to my issue, basically am stuck on grub rescue after a normal shut down in on windows on a dual boot system. Here's the events leading to this problem. BTW am on windows 10.

I have a 1TB HDD on a Toshiba C660, my HDD partitions were as follows all in numeric order according to minitool partition (and this is if I remember correctly): 1.Windows system reserve 100GB 2.Windows installation C:\ 160GB 3.Backup F:\ 600GB(made by me for storing data) 4.Unallocated space (140GB). This was primarily how my HDD was after I reset it with a complete clean leaving only 130GB of data in the Backup partition. I left the remaining 140GB unallocated because I was planning to install Ubuntu Linux the way I did alongside windows 8 previously, as it turned out windows 10 had an issue of not being detected by the live CD installation of ubuntu. So I searched the web for some fixes and I came across a guide that explained how to manually set up portions to install it alongside by making the "/ 32Gb" , /home 100Gb and "swap 8Gb" partitions all went well with the system going through grub on each startup, since I had the backup part I on in mind as a sort of portal to shared files for both systems I was punched in the face the face by the unmountable partition error which usually going through windows and shutting down fixed but this time it wasn't working, I even put the laptop on shutdown ,disconnected the charger and removed the battery for 10 minutes. Seeing as I couldn't use the backup partition as a shared one I had the problem of having no space for the data I wanted to have on the Linux side so I went back in windows and used minitool part I on to resize the backup drive leaving it at 380+GB and create a ext4 200Gb leaving an unallocated 15gb, the partition went successful and since the Linux portions weren't visible from windows I thought if maybe I did a shutdown once more and when I got to the Linux side it would allow me to see and copy the data I needed for once to the new partition. And lo and behold on startup I got a black screen with an error saying.

Error: file '/boot/grub/i386-pc/normal.mod' not found. Entering rescue mode... grub rescue>

After the making of Linux and creating of a second backup partition, the partition list was as follows (continuing from original layout). 4.Linux Backup 200Gb 5.Unallocated space 15Gb 6. / root 32Gb 7. /home 100Gb 8.Swap 8Gb. From when I only installed Ubuntu it was 123 and 678. The was another hidden partition on the windows side but it was hidden and I don't remember were it was between the other partitions.

  • Better to see details: Post the link to the Create BootInfo summary report. Is part of Boot-Repair: help.ubuntu.com/community/Boot-Info But be sure you have turned off Windows fast start up which is always on hibernation. And it keeps all NTFS partitions mounted, so you cannot use them from Linux.More explanation of NTFS driver & Windows hibernation askubuntu.com/questions/145902/… – oldfred Mar 5 '16 at 17:40
0

You can try reinstalling grub to the hard disk from the Ubuntu Live CD. That should at least get your Linux working. If Windows doesn't work, you can boot from it's install media and there should be a rescue mode that will let you reinstall it's bootloader, and then you'll have to go back and reinstall grub again.

  • How do I run the live CD from grub rescue commands because that's all I get to on each startup. – Crash0varide Mar 5 '16 at 19:15
  • After the suggestion of running the live CD I went looking for ways to run CD drive through rescue mode and I came across this guide: unix.stackexchange.com/questions/148041/recovering-from-grub-rescue-crash and the one made by Gibaldo worked for me, thanks for the input – Crash0varide Mar 5 '16 at 20:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.