0

Ubuntu 15.10 Suspend / Resume blackscreen caused by Broadcom driver after no-internet install of drivers.

On a Dell XPS 15 with a Broadcom BCM4352 [14e4:43b1]

On a clean install of Ubuntu 15.10 the network card is not recognized. I can suspend the machine and it wakes up fine. After looking around a lot

After looking at this: Installing Broadcom Wireless Drivers and this:How to install Broadcom wireless drivers offline?

I pick these from the install USB: pool/main/d/dkms/dkms_XXXXX.deb pool/restricted/b/bcmwl/bcmwl-kernel-source_XXXXX.deb and run this command: sudo dpkg -i *.deb

After this the card works (if I reboot it will ask me for the wireless password before logging in, even if I have clicked let all users use the card).

The big problem is I cannot suspend resume. On suspend, it will suspend, on resume, it looks like it starts up, but then nothing happen and I get the infamous blackscreen.

I have tried to update the machine after, I have tried just about any graphics driver, and nothing changes.Its on the broadcom driver install this happens.

Any ideas?

  • This is a bug of Broadcom drivers. Report it to launchpad. – Pilot6 Mar 6 '16 at 11:05
0

Replacing the Broadcom wireless card that came with my XPS 15 with an Intel Dual Band Wireless-AC 8260 worked for me - I can finally resume my system after being suspended.

Notes:

  • The Broadcom card is 3x3 and the Intel is 2x2, so replacing the Broadcom with the Intel would leave 1 antenna disconnected
  • I used this video as reference when switching the wireless cards
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.