I don't know how to access Skype in Ubuntu 11.10 because it gives me some error when I press the Skype icon on Unity launcher.

Here is a screenshot. Skype error message.

It's obvious that another instance of Skype is running but I don't know how to access it.

What could be the problem?

  • Try open a terminal and type <i>killall skype</i> and then try starting skype again. Or you could go to "System Monitor" the find skype in the list of processes and click "End Process" at the bottom right corner. – choel Oct 31 '11 at 22:41
  • Why to kill Skype process? I am asking how to access already running Skype. – Иван Бишевац Oct 31 '11 at 22:51
  • Did you install Skype from partner repository or from Skype website? – igi Oct 31 '11 at 22:53
  • I think it was from Skype website. – Иван Бишевац Oct 31 '11 at 23:14
  • aptitude may not list skype even with Partner Repository registered. To install search for Skype in the Ubuntu Software Center this will automatically install everything required even on 64-bit. – user46560 Feb 15 '12 at 19:05
up vote 12 down vote accepted

I found solution. After first signing in, I opened options, and checked option "Start Skype minimized in the system tray". Here is screenshot: enter image description here

EDIT: After there steps I had to do one more step. After typing next command into terminal:

gsettings get com.canonical.Unity.Panel systray-whitelist

I've got this:

['JavaEmbeddedFrame', 'scp-dbus-service', 'Wine']

I've just added Skype into this list issuing this command:

gsettings set com.canonical.Unity.Panel systray-whitelist "['JavaEmbeddedFrame', 'Skype', 'scp-dbus-service', 'Wine']"

You don't need to check Start Skype minimized... for this to work - as soon you as you update gsettings the skype icon will appear.

Hope this helps :)

  • That's not going to fix it. There are many posts on this same bug, see the sidebar or search here for 'Skype single instance' for more info. The root cause is that Skype just stops working with no indication it has stopped, and does not properly shut down. I hope for an update someday from Skype but I have uninstalled it for now as it is totally unreliable and no longer functions on my machine. – Tom Brossman Nov 3 '11 at 16:33
  • 1
    @TomBrossman: did you reinstall Skype? I hope you made sure to do that before saying "That's not going to fix it". – RolandiXor Nov 3 '11 at 17:26
  • @Roland Taylor I did, I also tried a few other suggestions like deleting the .skype folder. It didn't work for me, and I suspect the OP will experience the same bug continuing. If it works for someone else, great. I can always edit my comment if I see others having success with this method. – Tom Brossman Nov 3 '11 at 19:05
  • @TomBrossman: I deleted .Skype dir and after checking "Start Skype minimized in the system tray" option, for me now works. – Иван Бишевац Nov 3 '11 at 19:05
  • @Иван Бишевац glad to hear it. I had the same problem, tried the same thing, and Skype still silently crashed every single day. Hope you have better luck. Also, now that I said I can edit my original comment, I don't see how. D'oh! – Tom Brossman Nov 3 '11 at 19:48

Try to reinstall official Skype version for Oneiric. Open a terminal and type:

sudo apt-get remove skype
sudo apt-get update
sudo apt-get install skype

Then restart your system.

  • Running the first command with purge instead of remove will completely remove Skype, along with (possibly) faulty configuration files, from your system. – Christopher Kyle Horton Nov 3 '11 at 13:47
  • @WarriorIng64: not from your home folder though. – RolandiXor Nov 3 '11 at 17:25
  • 1
    what software source do you need to have enabled for this to work on AMD64? I can't install skype using apt-get, it tells me that there is no installation candidate. – Igor Zinov'yev Nov 15 '11 at 7:51
  • 2
    @Igor Zinov'yev: you should activate the Partner repository. – igi Nov 15 '11 at 21:51
  • This worked great for me, thanks for the suggestion! – slacy Nov 18 '11 at 17:03

I had a similar issue where another instance of Skype wasn't running. From this answer on my question, can you try deleting the ~./Skype hidden folder after backing it up, then rebooting and restarting Skype?

The real problem here is that under Unity, the Skype icon doesn't appear in the tray when it is running. When you close the Skype window, the Skype process is still running as you expect, only there is no tray icon to show that it is. After you change com.canonical.Unity.Panel systray-whitelist as described in #2, the icon appears (on next log in, for me), and it is now obvious when Skype is running, and when it is not.

What I can't tell you is why this white listing was added...

Make sure these two packages are installed.

sudo apt-get install sni-qt sni-qt:i386

It happened to me that Skype did not started minimized to tray, and I had marked the option "start skype minimized"...

I found out this was because I was launching skype from a shell script, with the "--pipelogin" argument - which seems to make skype ignore the "start minimized" setting

Hope it helps someone

You can activate Keyboard hotkeys in options. "Focus Skype" is Ctrl+Shift+# by default. keyboard shortcut to focus skype

  • Welcome to askubuntu! Would you be so kind as to add versions to your answer? Like the version of skype to which your answer applies? I thank you and the community thanks you! – Elder Geek Mar 27 '15 at 15:11

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.