0

Right now I'm trying to install Ubuntu 15.10 on an Asus GL552 that came with Windows 10 and has an NVidia 960M GPU.

I've disabled Secure Boot, Fast Boot, and enabled CSM in my BIOS, but when I boot to the flash drive and select either Try or Install Ubuntu, I see:

[ 0.043200] Ignoring BGRT: invalid status 0 (expected 1)
[ 3.978792] nouveau E[ VBIOS][0000:01:00.0] 0xf152[0]: unknown opcode 0x00
[ 3.978813] nouveau E[ DEVINIT][0000:01:00.0] init failed, -22
[ 3.978828] nouveau E[ DRM] failed to create 0x00000080, -22

After searching a little bit, I found that I should put nomodeset in the startup parameters, at which point I don't receive the nouveau errors, but the screen has been sitting at the same "Ignoring BGRT" message for over 15 minutes.

I also have dual hard drives, one an M.2 SSD and the other a SATA HDD. At this point I haven't even gotten to any install prompts as it doesn't go past the errors after Grub.

I've tried 14.04 LTS, however the screen just stays black and doesn't give any errors or makes any progress. How can I get past this point?

  • Probably best to have 16.04, older versions will not have drivers for newest hardware. But if 14.04 works stay with it. As there is an issue with new Intel Skylake video. See: wiki.ubuntu.com/XenialXerus/ReleaseNotes – oldfred Apr 27 '16 at 20:13
1

I was able to get 15.10 installed by doing this:

Modify /etc/grub.d/10_linux so that any subsequent updates don't overwrite the grub.cfg file and thus your modifications.

sudo -H gedit /etc/grub.d/10_linux

Look for line 177. It should start with

linux    ${rel_dirname}/${basename}.efi.signed root=${linux_root_device_thisversion}

After ro, add

nmodeset acpi=0 acpi_osi=linux acpi_backlight=vendor noalpic i915.preliminary_hw_support=1

Save and close, and then update grub:

sudo update-grub

Based on a post at Ubuntu Forums.

Then for 16.04 I used these params instead:

i915.preliminary_hw_support=1 nouveau.modeset=0 acpi_osi=! acpi=0 acpi_backlight=vendor idle=nomwait
0

"Nouveau" is graphics driver for NVIDIA card. Your laptop has hybryd graphics, do try disabling NVIDIA card in BIOS and running the install using Intel graphics, that solved a similar problem for me.

  • I can't find an area in my BIOS to disable the NVIDIA card. I currently have an Aptio Setup Utility with very limited options, and can't find a way to upgrade it to the EFI gui. I was able to disable the card in Windows Device Manager, which allowed the text to get a lot further, but it froze again - presumably because the NVIDIA card wasn't disabled in the BIOS. Any tips on being able to disable a GPU in the BIOS? – user198881 Mar 5 '16 at 19:44
0

As far as I can see the Nvidia card can't be disabled in the bios.

I have tried everything I can find/think of to get 15.10 installed but it always fails at some point. Even trying Ubuntu Server 15.10 doesn't work, it just goes to a blank screen. Minimal freezes while choosing language. Desktop 15.10 while trying nomodeset gets so far but freezes, trying nouveau.noaccel=1 by itself and in combination with nomodeset gets so far but freezes. 16.04 Beta2 has the same issues.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.