4

When running sudo apt-get update I get the error:

Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release Unable to find expected entry ‘main/binary-i386/Packages’ in Release file (Wrong sources.list entry or malformed file)

But this used to work until a few days ago. The mentioned web address dl.google.com/.../stable/Release actually exists but it contains only Architectures: amd64. The error message mentions binary-i386, which is not amd64.

I tried all the usual fixes for general "Failed to fetch" problems but it did not make any difference in this case. Any suggestions? How can I fix the error message?

0

2 Answers 2

11

This is because Google has stopped support for 32-bit version of chrome or chromium.

Please edit /etc/apt/sources.list.d/google-chrome.list, replace the line

deb http://dl.google.com/linux/chrome/deb/ stable main

By

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

You should also check other sources list under /etc/apt, especially /etc/apt/sources.list, remove any line including http://dl.google.com/linux/chrome/deb/. The following command would help you find out such files.

grep "http://dl.google.com/linux/chrome/deb/" -r /etc/apt
0

Try the instructions here:

https://www.reddit.com/r/chrome/comments/48oje6/linux_how_to_fix_failed_to_fetch/

Worked for me

1
  • 2
    Good practice is to add some info to your post, so it will remain valuable if the link will be broken.
    – whtyger
    Commented Mar 6, 2016 at 5:58

Not the answer you're looking for? Browse other questions tagged .