2

I accidentally made GNOME-Shell unusable by testing a theme which completely broke the environment. After I've logged in nothing happens, all I get is an empty desktop.

I can't change the GNOME-Shell theme through gnome-tweak-tool when I'm not currently running the GNOME-Shell so how can I change this manually? There must be a value in gconf or something that I can edit to restore the shell, right?

Please help me out here? :)

4

First you need to get hold of a theme, if you don't got one you can find one here. After you downloaded the theme, unzip it to "/usr/share/gnome-shell/theme". Then you can reload gnome-shell by ALT+F2 and typing gnome-shell --replace Or just log out and back in again.

Hope it helped.

  • Thank you for the help, though I solved it by removing the GNOME-Shell user settings file in ~/.config/dconf/ I guess your way of solving it would be better since I needed to reconfigure all my personal settings after doing this but it worked at least :) – Niklas Nov 1 '11 at 9:36
1

Or you can use this command:

gsettings set org.gnome.shell.extensions.user-theme name SHELL_THEME

Example:

gsettings set org.gnome.shell.extensions.user-theme name Adwaita

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.