I recently installed Ubuntu 15.10.

Previously, I had Ubuntu 15.04. In 15.04, I had this entry in my fstab file to mount an external hard drive that is attached to my wireless router:

//rt-ac87r-8b48/My_Book /media/rt-ac87r-8b48 cifs user,guest,uid=1000,gid=users,iocharset=utf8,sec=ntlm,file_mode=0777,dir_mode=0777,_netdev,noperm 0 0

In 15.04, this worked great - at boot, the drive mounted.

In 15.10, with the exact same fstab file, I get no error messages, but this drive does NOT mount at boot. I have to manually mount it (which works fine).

I'm at a loss as to what to look at next to figure out why this will not work. I have the cifs tools installed in 15.10 (as they were in 15.04).

  • I had to add the option vers=1.0 for it to work. Oct 4, 2021 at 23:28

2 Answers 2


This row from fstab works fine on my kubuntu 15.10

// /home/user/myshare cifs username=<yourusername>,password=<yourpwd> 0 0

It seems _netdev stopped working in a lot of Debian distros around this time. I had the same problem but using x-systemd.automount instead, as described in this answer, fixed it for me.

Your fstab entry should look like

//rt-ac87r-8b48/My_Book /media/rt-ac87r-8b48 cifs user,guest,uid=1000,gid=users,iocharset=utf8,sec=ntlm,file_mode=0777,dir_mode=0777,x-systemd.automount,noperm 0 0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .