15

I'm experiencing some keyboard shortcuts not working in VLC after upgrading to 15.10. The problem persists in 16.04

If I just open VLC with no file loaded, almost all shortcuts involving Ctrl do nothing. Ctrl+O should open the "open file" dialog, but nothing happens. The exception is Ctrl+Q which does work to close VLC.

Oddly, if I open a file then Ctrl-W starts working to close the file, but none of the other Ctrl shortcuts work.

Stranger still, after I've opened a file and then closed it, suddenly all the Ctrl shortcuts start working, but now the menus have changed color and no longer sit within the window title bar.

What could be causing this strange behaviour, and how can I fix it?

VLC before opening and closing a file

VLC after opening and closing a file

  • I am experiencing the same problem – salih kallai Apr 22 '16 at 20:21
  • 1
    Say, is this still an issue in 16.04? – anonymous2 May 30 '16 at 13:50
  • 1
    @anonymous2, yes, the behaviour is the same in 16.04. The only difference I can see is that the hotkeys that don't work are now no longer listed alongside the menus until having opened and closed a file. – Ian Mackinnon May 30 '16 at 14:00
  • 1
    When logging out from a Unity session and logging in to LXDE, all shortcuts work right away. So it's very clearly a Unity related problem. – Thomas W. Sep 11 '16 at 5:39
  • 1
    Yup, can confirm this bug on VLC 3.0.0 too. – edwinksl Sep 11 '16 at 5:47
7
+50

This behavior is caused by a notorious appmenu-qt5 bug. The bug report is here. It sets an environment variable for qt applications and this causes many applications menu item to be problematic in Unity. VLC is one of them.

The environment variable is QT_QPA_PLATFORMTHEME and is set in the file /etc/profile.d/appmenu-qt5.sh.

Workaround

To workaround this bug, You can unset this variable and start VLC then. From terminal you can use this command to start VLC without this bug.

env QT_QPA_PLATFORMTHEME='' vlc

As a permanent fix, first copy the vlc.desktop file to ~/.local/share/applicatons/

cp /usr/share/applications/vlc.desktop ~/.local/share/applications/

and then edit the line starting with EXEC to this line below

Exec=env QT_QPA_PLATFORMTHEME='' /usr/bin/vlc --started-from-file %U

Save the file. Now if you start VLC, the shortcut will work from start.

Update

As reported by Jonathan Y, it seems unsetting UBUNTU_MENUPROXY environment variable works too! So, you can use un-setting this variable in .desktop file.

Exec=env UBUNTU_MENUPROXY='' /usr/bin/vlc --started-from-file %U
  • 1
    Awesome, I can confirm the env command works as expected. :) – edwinksl Sep 11 '16 at 6:55
  • @edwinksl Great! thanks for testing and verifying the result – Anwar Sep 11 '16 at 6:57
  • 2
    I've also seen a recommendation to remedy this bug by unsetting UBUNTU_MENUPROXY in a similar fashion. Can you comment on the difference between the two approaches, and which (if any) is less restrictive / should be considered 'organic'? – Jonathan Y. Sep 11 '16 at 13:35
  • @JonathanY. I too has seen that recommendation. But After testing with that, I found no difference. What was your result using that one? – Anwar Sep 11 '16 at 13:41
  • 1
    Yes, I have the same functionality in vlc, unsetting either variable. Version 2.2.2 on Xenial. – Jonathan Y. Sep 11 '16 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.