2

After a clean install (pre-installed Win 10 removed) of Ubuntu 14.04.4 on Dell Inspiron 13-7359 I am not able to boot the OS in "Secure mode".

What was done:

  1. First installed standalone Ubuntu 15.10 - installation OK, but in BIOS there was no visible device (for EFI mode), which I could boot from. After several re-installations ("Auto" Erase and install, Manual partitioning, ...) there was no progress.
  2. Installed standalone Ubuntu 14.04.4. Installation OK, didn't boot to OS. BIOS found a disk to boot from, but this message appeared: "Operating system loader has no signature.". Tried Boot-repair from live disk - no progress. Pastebin report.

Current situation - Ubuntu boots in "Non-secure" Legacy mode. Everything works fine.

I'm curious what I did wrong, as there is always solution - I didn't find it, even there are some Q&A to similar problems Nothing helped me out of this.

Update:

After reading answers, identified that the problem probably lies in installation USB media, tried following solutions (8 GB USB flash formatted to FAT32 FS)

  • Disks (gnome-disk-utility) application in Ubuntu 15.10
    • created bootable Ubuntu 14.04.4 USB flash
    • media was not visible in ntb BIOS in UEFI & SecureBoot configuration
  • dd in terminal (Ubuntu 15.10)
    • created bootable Ubuntu 14.04.4 USB flash
    • not visible in ntb BIOS in UEFI & SecureBoot configuration
  • Rufus (in Win7)
    • Bootable USB flash with GPT for UEFI (Rufus option)
    • created Ubuntu 14.04.4 live USB flash
    • visible in ntb BIOS
    • din't boot in UEFI & SecureBoot configuration
      • Error Message: "Operating System Loader signature not found in SecureBoot database"
    • But USB booted successfully with UEFI On & SecureBoot Off configuration (path to boot file : /EFI/boot/grubx64.EFI)
    • Try to install in automatic mode "Erase and reinstall" offered to create only main ext4 and swap paritions
    • In "Something else" option, I was able to managed creating an ext4 main partition, a 8GB swap and a 601 MB EFI partition (previously reserved 201 MB was not enough for the installer)
    • Installation OK
    • After reboot SecureBoot enabled and booted in UEFI & SecureBoot configuration
    • Also there is a folder /sys/firmware/efi now (which should indicate that there was no fallback to compatibility mode)
    • => Problem Resolved
3
  • hi I really like to buy this laptop too, do you have any problem or shortkey that doesnt work? thanks for posting this question Sep 27 '16 at 14:41
  • 1
    No problems at all, just touchscreen, which works, but there is no gestures support, it's not a tablet, but touch screen was not the reason to buy for me. I can recommend this product.
    – klimpond
    Sep 28 '16 at 12:36
  • wow cool will buy this one, okay thanks for you reply Sep 28 '16 at 15:08
3

You've installed Ubuntu in BIOS/CSM/legacy mode. I recommend you disable the Compatibility Support Module (CSM; aka "legacy boot support" or similar terms) in your firmware. Doing this will render some boot media unbootable. If you run into this problem, the solution is to fix the boot media. If you want to boot in EFI/UEFI mode, enabling the CSM is the worst thing you can do. For more on this subject, see my Web page about it.

Note that in EFI mode you do not boot from a "device"; you boot from a boot loader file, which is stored on the FAT EFI System Partition (ESP) and referenced in an NVRAM boot manager entry. There is one sort-of kind-of exception to this rule: EFI supports a "fallback" boot filename, which is EFI/BOOT/bootx64.efi for 64-bit (x86-64) systems. If no other boot entry is valid, or sometimes if there's an explicit entry for this loader, the system will boot it. This feature enables booting from OS installation media. It's also sometimes used to boot systems with badly broken EFIs that ignore or forget their NVRAM entries. This fallback entry may appear in the computer's built-in boot manager much like a traditional BIOS boot-from-device entry, but it's not quite the same thing.

4
  • Ok, great article. I agree, that all the install tries were in CSM mode, caused by the fallback as Secureboot was enabled and CSM disabled during install. I will start with fixing USB install disk and try to reinstall the OS.
    – klimpond
    Mar 4 '16 at 22:35
  • Find solution in creating USB flash in Rufus Win app. See my update in question, where are tried approaches explained in detail. P.S.: Feel ashamed to resolve Linux problem by Win app.
    – klimpond
    Mar 7 '16 at 13:26
  • Can you please confirm, that existence of /sys/firmware/efi folder is 100% indication of booted OS in EFI mode?
    – klimpond
    Mar 7 '16 at 13:27
  • 1
    Yes, the presence of /sys/firmware/efi indicates an EFI-mode boot. (I suppose it might be fakable in a BIOS-mode boot, but Ubuntu certainly doesn't do that by default.)
    – Rod Smith
    Mar 7 '16 at 13:50
0

You seem to have the 32 bit Ubuntu edition installed.
You have to install the recommended 64 bit version.
Otherwise the installation cannot work in EFI mode.

However ... to solve your problem ...
Boot from Ubuntu installation media.
Select 'Try Ubuntu without installing'.

Open GParted from the dash.
Click on Device in the top menu.
Click on Create Partition Table.
Select gpt as you have EFI BIOS.

Create a new partition - format it with fat32 - size of about 100 MB.
Create a new partition - format it with ext4 - size fitting your needs.
Create a new partition - format it with swap - size matching the RAM.

On the desktop click Install Ubuntu, when asked choose Something else.
Select the ext4 partition you had created with GParted for Ubuntu before.
Select / as mount point and ext4 file system as format, start the installation.

5
  • 1
    I don't think it's a 32-bit installation. Certainly the boot from which Boot Repair was run is 64-bit (as indicated by the bootx64.efi boot loader filename). The only references I can see that might lead one to think it's a 32-bit install are "i386" strings, but those are in reference to GRUB, where that string indicates a BIOS-mode install, not a 32-bit install.
    – Rod Smith
    Mar 4 '16 at 17:10
  • The installation USB disk was created from 64bit iso file using Ubuntu native Start up disk creator.
    – klimpond
    Mar 4 '16 at 22:28
  • I had the three partitions you mentioned. But the 200MB fat32 partition was was somehow ignored during install.
    – klimpond
    Mar 4 '16 at 22:30
  • @klimpond : Maybe the USB installation media is not configured properly - Startup Disk Creator is known to having issues - create the media the way as it is described here : askubuntu.com/questions/700807/… :)
    – cl-netbox
    Mar 5 '16 at 10:21
  • gnome-disk-utility didn't help me out of this problem - media not visible in BIOS with UEFI & SecureBoot on, resolved with Rufus app.
    – klimpond
    Mar 7 '16 at 13:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.