I am currently using Ubuntu 10.04 LTS and when I run the update manager it doesn't show the new release.

  • I have checked the "Software Sources" update tab to make sure "release upgrade" is set to Normal.
  • I'm receiving updates from the "Main Server".
  • I've tried running update-manager and checking a few times to make sure there's nothing to update to
  • I've run "update-manager -c"
  • I've run "update-manager -d"

but it still doesn't show, and I can't find an answer on Google.

I turn to you, Help!

2 Answers 2


On LTS versions of Ubuntu the default behavior is to not alert you about new releases unless they are LTS releases. To change this go to:

  1. System > Administration > Software Sources
  2. Click the Updates Tab
  3. Change the "Show new distribution releases" to "Normal Releases" (the pull down box is under the Release Upgrade section).
  4. After doing so Software Sources should ask you to refresh your repositories
  5. After refreshing go to the Update Manager (System > Administration > Update Manager) and a button to upgrade to Maverick will be revealed
  • Thanks for that, I did have Normal Releases set, which is what confused me. All fixed now though!
    – Sam L
    Commented Oct 15, 2010 at 9:51
  • Much simpler for us regular users than editing the sources list :)
    – Jono
    Commented Oct 29, 2010 at 9:33

Have you refreshed the update manager? Normally it checks every day for new releases, but it sometimes doesn't, so make sure you have clicked the Check.

If this still doesnt work, make sure that you have installed all updates to 10.04, and then click Check again.

If these don't work, check that the software sources made the release upgrade check to normal, by checking the /etc/update-manager/release-upgrades file and making sure it says Prompt=normal.

If after these you still can't see it, try doing this on the command line:

"sudo apt-get update && sudo apt-get upgrade"
"sudo do-release-upgrade"

That should work.

If it still doesn't work, then edit your /etc/apt/sources.list file, editing all occurences of lucid with maverick and then sudo apt-get update && sudo apt-get dist-upgrade

If after all this, it still doesn't work, I have no idea what else to do :-P

  • Cheers YaManiacKill, went down the list, and the one that worked was editing the sources.list file. You're a champ! :)
    – Sam L
    Commented Oct 15, 2010 at 6:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .