1

I've tried to install Ubuntu on a laptop, and despite the fact that the OS works perfectly fine on a computer that I used the same USB with Ubuntu 14.04 LTS that works perfectly, however the laptop has the error message in the title. Checking all of the similar questions, I believe my situation to be unique because the output of blkid produces

/dev/loop0: UUID="10d2b97a-01fb-449e-b1d9-f20307d5856f" TYPE="ext2"
/dev/loop1: TYPE="squashfs"
/dev/sda1: UUID="9a1b340b-05d9-49bc-9aff-4221cc24dd5d" TYPE="ext4"
/dev/sda2: UUID="c685c3c2-c148-454a-b105-2826ae125607" TYPE="ext4"
/dev/sda3: UUID="ce995684-4dab-40cb-81fb-7edb5ba3b194" TYPE="swap"

and /etc/fstab shows

overlay / overlay rw 0 0

tmpfs /tmp tmpfs nosuid,nodev 0 0

/dev/sda3 swap swap defaults 0 0

I have tried updating grub (which I believe I should mention advanced mode doesn't work), boot repair (including replacing and updating the grub options), and even tried uninstalling a number of times (want to put the ephasis on how the OS works on my desktop perfectly fine, so thought it might have installed incorrectly) and none of those fixes worked.

Wanted to also note that my research indicated that the loop0 was supposedly a dual boot thing, which doesn't sound right, because it's just Ubuntu on the laptop.

  • 2
    Have you tried updating the BIOS/UEFI? – QwertyChouskie Mar 3 '16 at 22:09
  • 1
    That, I haven't tried. Will look into that – Marcellus Walden Mar 3 '16 at 22:15
  • The loop devices are how the live usb works and have nothing to do with your hard disk. The /etc/fstab taken from the live usb is also useless. Does the "xxxx" in the error match one of the UUIDs listed for sda1 or sda2? It would be better to run lsblk from the system on the disk when you get the error rather than from a live usb. – psusi Mar 4 '16 at 0:40

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.