I have MSI GP60 2QE laptop with Intel HD 4600 and NVIDIA 940M graphics. I dual booted Windows 10 with Ubuntu 15.10 and noticed, that on Ubuntu NVIDIA card is always on what makes my battery last about 2h. Can I disable that card and force system to run on Intel integrated graphics? I use Ubuntu only for coding so I don't need advanced graphics enabled. Also, I can't disable card in BIOS since I'm using it on Windows.

  • Bumblebee might be a good solution? It will use the integrated graphics by default, but you can still run heavier applications with your NVIDIA card if necessary. wiki.ubuntu.com/Bumblebee Mar 16, 2016 at 16:21
  • Currently I have my NVIDIA card fully Disabler, but I think I'll give it a shot. Thank you :-)
    – ikurek
    Mar 16, 2016 at 16:47

1 Answer 1


Yes, you can:

  • Open NVIDIA X Server Settings.
  • Go to PRIME Profiles.
  • Select Intel.
  • Log out and back in or reboot.

Now you are using Intel graphics.

enter image description here

Update addressing your comments that you cannot access NVIDIA X Server Settings:

To open NVIDIA X Server Settings press the Super key (it's the Windows key) and type "NVIDIA".

If it doesn't appear, maybe the installation of the NVIDIA drivers is not complete.
In that case, open a terminal and execute:

sudo apt-get update  
sudo apt-get install nvidia-prime nvidia-settings

Then look for it again and you will find it.

  • I can't find X Server Settings, do I have to set anything to see them?
    – ikurek
    Mar 3, 2016 at 16:49
  • I know, but no results are found...
    – ikurek
    Mar 3, 2016 at 16:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .