Starting March 2016, Software Updater displays "Failed to download repository information," and "Check your internet connection when attempting to update." What's causing it and how can I fix it so I can update my computer?

I have Google Chrome installed and I'm running Ubuntu 14.04 64bit.



When you install Google Chrome, it adds its own repository to your system so that it can be updated via Software Updater. Around the beginning of March 2016, Google dropped their 32bit builds for Chrome. On 64bit Ubuntu, Software Updater expects to see both 32bit and 64bit versions of packages in a given repository. Since Google removed the 32bit version, Software Updater can't find that package anymore and produces an error that shows up as Failed to download repository information, Check your internet connection.

Fix the repo

In order to fix this, you have to tell the package manager that the Google repository is 64bit-only. To do this you have to edit the Google repository file to add [arch=amd64] after the deb at the beginning of the line. The following snippet will check if the error is indeed with the Google repository and make the change for you. Make sure you copy the whole snippet (it's one line) and paste it in your favorite terminal:

url=http://dl.google.com/linux/chrome/deb/; if sudo apt-get update 2>&1 >/dev/null | grep --quiet "$url"; then for file in $(sudo grep -Rl "deb $url" /etc/apt/); do sudo sed -i 's/^deb/deb [arch=amd64]/' "$file"; done; fi

Upgrade Chrome

Close and re-run Software Updater and upgrade Chrome to the latest version - 49.0.2623.87-1 or later.

| improve this answer | |
  • did not work.. 16.04 – rowntreerob Jun 13 '16 at 14:14

I added [arch=amd64] to the /etc/apt/sources.list.d/google-chrome.list as suggested but was still getting the error.

I noticed there was a second possible reason for the error.

On my system there is a file called additiona-repositories.list in /etc/apt/sources.list.d. This file also needed the [arch=amd64] added in order to clear the error.

I added directly to the url using the update manager "mintUpdate" by clicking on edit>software sources, entering my password, selecting "additional repositories (on the left), highlighting the item that matched:

deb http://dl.google.com/linux/chrome/deb/ stable main

Clicking "Update URL" and adding [arch=amd64] just after the deb as such:

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

Though it's not as fancy as the terminal method it'll work for those of us that are GUI oriented.

| improve this answer | |
  • Thanks for the tip. Updated the snippet to catch that case as well. – Nicolay Doytchev Mar 3 '16 at 20:31
  • 1
    after updating package: google-chrome-stable, old version:48.0.2564.116-1, to new version: 49.0.2623.75-1 the [arch=amd64] was removed from the file: /etc/apt/sources.list.d/google-chrome.list had to re-add it – Nich Mar 3 '16 at 23:06
  • 1
    Since I cant comment on original post I have to place it here. Running the command "url=dl.google.com/linux/chrome/deb; if sudo apt-get update 2>&1 >/dev/null | grep --quiet "$url"; then for file in $(grep -Rl "$url" /etc/apt/); do sudo sed -i 's/^deb/deb [arch=amd64]/' "$file"; done; fi" (without the quotes) when the URL already contains [arch=amd64] results in a second copy of it causing another error (of course that's my fault for doing it twice but a warning or a modification to the command might be wise. – Nich Mar 3 '16 at 23:13
  • Yeah, it doesn't guard against existing [arch=amd64] tag. I might add a check for that. Although the script isn't foolproof if the preconditions aren't met. – Nicolay Doytchev Mar 4 '16 at 6:03
  • Fixed. Changed the matching token for finding the Google repo files so that it wouldn't match ones with [arch=amd64]. Now if you have multiple lines in one file and one has that while another doesn't, then the file will be matched and the line that has the tag will be duplicated again. But I'm not fixing that. If a user goes to the length to do such granular modifications themselves, they can fix it just like you did. :) This is meant to be a quick copy-paste fix to be used by casual users until Google fixes their bug. – Nicolay Doytchev Mar 4 '16 at 6:20

I'm using 14.04 64 bit and also getting "Failed to download repository information". I used the code snippet. I then ran the software updater ... It ran perfectly and I updated to the latest google chrome.

I ran the software updater a second time. Now I get the error "Failed to download repository again". I examined the /etc/apt/google-chrome.list file and found the [arch=amd64] missing. However, the /etc/apt/google-chrome.list.save file did contain the [arch=amd64].

So I ran the code snippet again. The software updater now runs without error. And the /etc/apt/google-chrome.list file contains the [arch=amd64].

It appears to me that updating chrome will automatically generate a new /etc/apt/google-chrome.list file without the [arch=amd64] ... forcing you to re-run the code snippet again. So the snippet is a temporary fix until the file is again automatically generated.

Note: This is the contents of my /etc/apt/google-chrome.list:

# You may comment out this entry, but any other modifications may be lost.
deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
| improve this answer | |
  • Yes, that's the gist of it. It's a bug in Google Chrome that they update the repo without specifying that it is 64bit only. So you have to re-run it until they change that. – Nicolay Doytchev Mar 5 '16 at 3:56

Quick short term solution for Ubuntu (14.04)

  • start software updater
  • wait for the 'Failed to download repository information' error
  • select 'settings...'
  • select 'close'

now the updates are available :-)

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.