After the installation of Ubuntu 14.04 on my acer Aspire E 11 laptop the touchpad was working normally. Two days later I accepted the upgrades shown in the Software Updater, then it won't be recognized anymore. The touchpad seems to left click, but won't move or right click. The update installed the following:

linux-generic-lts-wily linux-headers-generic-lts-wily linux-signed-image-generic-lts-wily linux-image-generic-lts-wily linux-signed-generic-lts-wily

I tried uninstalling these Packages and installing older linux-headers versions, but after selecting them in the grub menu even the wireless mouse won't work. What can i do to make my touchpad work again? Here is some additional information:

  • xinput gives:
⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                       id=10   [slave  pointer  (2)]
⎜   ↳ Logitech USB Receiver                       id=11   [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Video Bus                                   id=7    [slave  keyboard (3)]
    ↳ Power Button                                id=8    [slave  keyboard (3)]
    ↳ Sleep Button                                id=9    [slave  keyboard (3)]
    ↳ HD WebCam                                   id=12   [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=13   [slave  keyboard (3)]
    ↳ Acer WMI hotkeys                            id=14   [slave  keyboard (3)]
  • The package


is installed. I can't install the package xserver-xorg-input-synaptics, as the system complains:

Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable distribution that some required packages have not yet been created or been moved out of Incoming. The following information may help to resolve the situation:

The following packages have unmet dependencies: xserver-xorg-input-synaptics : Depends: xorg-input-abi-20 Depends: xserver-xorg-core (>= 2: E: Unable to correct problems, you have held broken packages.

  • I also tried

sudo modprobe -r psmouse && sudo modprobe psmouse proto=imps with the old or new kernel loaded, and still nothing.

  • dconf-editor is unable to find the touchpad.
  • Forcing a install of xserver-xorg-input-synaptics with aptitude forces a lot of stuff to be uninstalled, so that the whole system won't boot and I all get is a black screen. (I formatted the system since then. At the first time i installed ubuntu 14.04, i clicked the automatic download of updates, so from beginning on the touchpad wasn't working)

I don't want to upgrade to Ubuntu 15.10, because the computer will constantly completely freeze and I have to hard reset it.

Thank you for the help!

1 Answer 1


This has been reported as a bug https://bugs.launchpad.net/ubuntu/+source/linux-meta-lts-trusty/+bug/1558489

It appears to be an issue with kernels above 3.19.0-51. I have exactly the same problem. The solution (for now) is to boot using kernel 3.19.0-51, as explained in How can I boot with an older kernel version?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .