1

Repository version (0.11) contains bug and I've tried to install the latest version from source but has failed - cmake wants some ecm-config files which I can't find. How to install this thing properly? What commands should I type?

http://download.kde.org/stable/rsibreak/0.12/

Update 1:

It looks like I haven't this package in repo. apt-file even after update returns empty output and apt-get says Unable to locate package extra-cmake-modules.

I'm also very confused with general cmake usage. With make things are simple: you type ./configure then make then make install. But with cmake things are different. Right now I'm using scary copy-paste command from internet cmake -DCMAKE_INSTALL_PREFIX:PATH=./build-dir -DCMAKE_BUILD_TYPE:STRING=Release . and I'm unsure if this is the right thing to do and why it is so complicated in the first place.

I'm afraid I need a total noob guide for this install case.

Update 2:

I've tried to add the xenial repository and install rsibreak from it but even with -t xenial apt-get was installing the old version. Then I've tried to install it as a deb package and it had the dependency of libkf5configcore5. Then I've got a bright idea to try to download and install libkf5configcore5 deb package and it failed to install but during the process of installation somehow ruined my system down to unrepairable state. So now I'm on 16.04, it has newest rsibreak in the repo and the question is no longer relevant.

  • Which version of Ubuntu are you installing on? There are issues with 1. non-existent extra-cmake packages with Trusty and older 2. Required version of qt5 dev files.in Trusty and older – andrew.46 Mar 5 '16 at 22:07
0
+100

Satisfying all dependencies can sometimes be a hassle when trying to build a package from source. You are probably missing the extra-cmake-modules package.

One tool that I find extremely helpful in diagnosing unclear dependencies is the apt-file utility that lets you search filenames of packages you don't have installed. Install apt-file and then run apt-file update to download the file cache. Then you can search to find what packages contain missing desired files.

$ apt-file search ECMConfig.cmake
extra-cmake-modules: /usr/share/ECM/cmake/ECMConfig.cmake
  • You may find it easiest to simply install the compiled package from Xenial (16.04) if rsibreak doesn't force many packages to be upgraded. You can add Xenial the repository with sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu xenial main" and then see what packages would be upgraded when installing rsibreak 4:0.12.1-1. – ebpa Mar 5 '16 at 19:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.