0

At work I print to a network printer, then release my print at any one of the hundreds of printers dotted around campus. The make and model show up as:

Sharp MX-5141N PS, 1.0

I set my computer up to connect to the printer on the appropriate URI using the ldp: protocol. I install the provided ppd driver. Once I've done this I can print to the network printers for a short time.

My question is that after a short amount of time (typically < 12 hours) Ubuntu automatically updates the printer I just set up and replaces the ldp with a local connection to the same printer shared through a colleague's MacBook. Through this indirect connect I can't (and don't want to) print.

How can I:

  1. Stop Ubuntu replacing my printer configuration with the shared printer it finds?
  2. Or, stop Ubuntu browsing for printers altogether (note: Browsing Off is already set in /etc/cups/cupsd.conf)

I've already checked out the responses to Stop Ubuntu discovering printers but this did not answer my question (I'm not looking to 'bump' my printer to the top of the list; I want to stop its settings being overridden).

Thanks.

0

I think I figured the issue out. When I set the printer up, I gave it the same name my colleague had (the default), so when rebooting this was updating my printer with my colleague's settings over the network.

To mitigate the issue, I set the printer up and gave it a unique name. This has now persisted through a couple of reboots, so I expect this has solved the problem (unless someone else on the network uses the name I've chosen!).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.