135

Getting below error message while issuing :

sudo apt-get update

Get:1 http://us.archive.ubuntu.com/ubuntu xenial InRelease [95.8 kB]
Ign:2 http://repo.mongodb.org/apt/debian wheezy/mongodb-org/3.2 InRelease                                                                                                            
Ign:3 http://dl.google.com/linux/chrome/deb stable InRelease                                                                                                                         
Hit:4 http://ppa.launchpad.net/canonical-x/vulkan/ubuntu xenial InRelease                                                                                                
Hit:5 http://repo.mongodb.org/apt/debian wheezy/mongodb-org/3.2 Release                                                                            
Hit:6 http://us.archive.ubuntu.com/ubuntu xenial-security InRelease                                                  
Ign:7 http://dl.google.com/linux/talkplugin/deb stable InRelease                                                     
Hit:8 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease                                                   
Ign:9 http://linux.dropbox.com/ubuntu wily InRelease                                           
Hit:10 http://ppa.launchpad.net/numix/ppa/ubuntu xenial InRelease                              
Get:12 http://dl.google.com/linux/chrome/deb stable Release [782 B]      
Hit:13 http://dl.google.com/linux/talkplugin/deb stable Release                  
Ign:14 https://apt.dockerproject.org/repo ubuntu-wily InRelease          
Hit:15 https://apt.dockerproject.org/repo ubuntu-wily Release            
Get:16 http://dl.google.com/linux/chrome/deb stable Release.gpg [181 B]  
Hit:17 http://linux.dropbox.com/ubuntu wily Release                                  
Get:20 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1,191 B]
Fetched 98.0 kB in 0s (118 kB/s)                                 
Reading package lists... Done
N: Skipping acquire of configured file 'main/binary-i386/Packages' as repository 'http://dl.google.com/linux/chrome/deb stable InRelease' doesn't support architecture 'i386'

This cuts across various releases of ubuntu

  • 5
    @Pilot6 (and others who voted for this question being off-topic): This is not specific to a particular Ubuntu version. It affects all users of Google Chrome on Ubuntu who have the Chrome repository enabled. – Gunnar Hjalmarsson Mar 5 '16 at 3:43
  • Chrome repository? – guntbert Mar 6 '16 at 18:45
  • @guntbert: I referred to Google's repository from where the updates are fetched. – Gunnar Hjalmarsson Mar 6 '16 at 20:59
  • 3
    @GunnarHjalmarsson what's the point of re-opening, since it's a dupe of askubuntu.com/questions/724093/… anyway? – muru Mar 6 '16 at 21:14
  • 4
    I can't see, why this should be a duplicate of the mentioned question. The source of the problem is the same, but the context is different (64 vs 32 bit). – Murmel Mar 9 '16 at 13:35
230

I tracked down offending repo (any for Google chrome in this dir)

cd /etc/apt/sources.list.d
grep chrome * | grep -v amd64

Now do same as below for each repo file which matches above

cat /etc/apt/sources.list.d/google-chrome-unstable.list

### THIS FILE IS AUTOMATICALLY CONFIGURED ###
# You may comment out this entry, but any other modifications may be lost.
deb http://dl.google.com/linux/chrome/deb/ stable main

SOLUTION : limit to just 64 bit by introducing the [arch=amd64]

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

ROOT CAUSE : Google dropped support for 32-bit Chrome on Linux triggering an error when updating apt in 64-bit systems (with multi arch enabled) ... details here : http://www.omgubuntu.co.uk/2016/03/fix-failed-to-fetch-google-chrome-apt-error-ubuntu

To confirm you are using 64 bit ubuntu with multiarch enabled issue

dpkg --print-foreign-architectures

if it says

i386

then you have added 32 bit support, this will list your native arch ... issue

dpkg --print-architecture 

if you are native 64 you will see this output so do SOLUTION shown above

amd64

Here is the command to remove multi architecture ( only if you have no 32 bit applications )

sudo dpkg --remove-architecture i386
  • 5
    This answer works very well (thank you!), however the file that needs to be edited (in your example /etc/apt/sources.list.d/google-chrome-unstable.list) is automatically configured on a regular basis, so the fix is written over and needs to be added over and over again. Any suggestions to overcome this? – sebpardo Feb 7 '18 at 3:21
  • 4
    @sebpardo, I reported it to google. Hope they fix it. – Elliptical view Feb 23 '18 at 4:50
  • 1
    @sebpardo I added an answer on how to automate the fix. – pLumo May 4 '18 at 13:38
  • 1
    many thanks for this solution. I didn't have any google sources, but this also worked for the virtualbox repository, which was flagging the exact same error message – verbumSapienti Aug 18 '18 at 13:13
  • 1
    ubuntu 18.04 user: works like a charm. thanks man. – Ali Jun 9 at 11:11
17

(this solution is for Ubuntu Bionic Beaver)
First, shame on Google for letting this issue linger so long!!

Here's how to fix it:
As already mentioned above, editing files in /etc/apt/sources.list.d seems to work... but only temporarily. The next day, the problem is back.

Here's why:

The file /etc/cron.daily/google-earth-pro runs daily and overwrites what you have in /etc/apt/sources.list.d/google-earth-pro.list.

To fix it once and for all, edit /etc/cron.daily/google-earth-pro.
Find this line:

REPOCONFIG="deb http://dl.google.com/linux/earth/deb/ stable main"

...and change it to:

REPOCONFIG="deb [arch=amd64] http://dl.google.com/linux/earth/deb/ stable main"
  • For immediate change for Google Earth, it might be worth editing the files google-earth-pro.list and google-earth-pro.list.save. – JayDin Dec 17 '18 at 4:12
  • The line to change would be at LINE 24 – Andor Kiss Jan 29 at 11:53
  • Thank you. [arch=amd64] solved my problem with virtualbox 6.0 – Simon Fontana Oscarsson Feb 23 at 21:58
  • 1
    Interesting, I did this AND the sources file still gets re-written. – Andor Kiss Mar 24 at 14:39
  • @AndorKiss Yes, that's what this cron job is doing. That's why this answer is here. – Colin 't Hart Apr 30 at 8:58
14

Changing

deb http://dl.google.com/linux/chrome/deb/ stable main

to

deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main

in each of

  • /etc/apt/sources.list.d/google-musicmanager.list
  • /etc/apt/sources.list.d/google-musicmanager.list.save
  • /etc/apt/sources.list.d/google-musicmanager.list.distUpgrade

seems to fix the issue for Google Music Manager for Play Music too. Not sure if it will revert these changes at some point as the files are automatically configured.

  • 2
    for me file to change was /etc/apt/sources.list.d/google.list – nazar_art Oct 27 '18 at 20:09
  • ### THIS FILE IS AUTOMATICALLY CONFIGURED ### # You may comment out this entry, but any other modifications may be lost. – Ferroao Aug 7 at 21:50
3

Although Google has fixed this issue for Chrome, it still appears for e.g. Google Earth.

Adding [arch=amd64] fixes the issue, but it needs to be added over and over again.

After making the file immutable as proposed by a webupd8 article and running into issues because of that, my current solution is to add a cronjob to apply the fix automatically once every hour:

~$ sudo crontab -e

0 * * * * sed -i 's/^deb http/deb [arch=amd64] http/' /etc/apt/sources.list.d/google-earth.list

(Replace google-earth.list if necessary).

  • Out of curiosity what keeps changing this file? In my experience, apt sources files don't get changed by themselves – Jonathan Jul 4 '18 at 15:20
  • Sergio Rus reckons that Google eventually fixed it for Chrome such that your one-time change would be preserved over updates. – Martin Dorey Jul 11 '18 at 23:25
2

Though this question has been marked solved, I was unable to solve this issue with any of the above answers. I used an another method. Go to 'software & updates' > ubuntu software > download from > select best server. Now wait for some time for the system to find it out. Once this gets done, try your command again. This worked for me.

2

Even if this question is marked solved, for me, on Ubuntu 18.04, changed a line in /etc/apt/sources.list from deb http://dl.google.com/linux/chrome/deb/ stable main to deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main.

There was no file named /etc/apt/sources.list.d/google-chrome-unstable.list. Making the same changes in /etc/apt/sources.list.d/google-chrome.list gave warnings saying that target package is configured multiple times. (in sources.list and google-chrome.list)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.