1

I have recently installed Linux (Lubuntu 15.10) on a computer that had running Windows Vista before and I'm stuck with enabling the wifi.

Two years ago, while still running Windows, the internal wifi card stopped working. I bought a USB wifi dongle to replace it and it worked fine.

On Lubuntu, the network manager shows both the internal wifi card (Ralink Corp. RT2790) and the dongle (Realtek 802.11n WLAN Adapter) as deactived. For both the message is "Wifi is disabled by hardware switch". The wifi dongle has no hardware switch. The internal card has a FN key combination. But it does not work and, as I said above, I was not able to activate it on Windows either.

I tested the dongle on another Linux computer (Xubuntu 15.10) and it worked fine (no blocking, was detected directly). Do you have any idea how I could activate the dongle? Or how I could activate the internal card, if that is easier to solve.

Running "rfkill list all" gives me

    0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
    1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no

which makes sense, because the dongle has no hard block feature.

ifconfig does not show the wireless (I'm currently connected via Ethernet):

      enp0s4    Link encap:Ethernet  HWaddr 00:e0:91:37:6a:8d  
      inet addr:192.168.0.13  Bcast:192.168.0.255  Mask:255.255.255.0
      inet6 addr: fd00:c47:3d3f:8cb2:a1ec:140e:7b80:e2ba/64 Scope:Global
      inet6 addr: 2a02:810c:800:2cdc:a1ec:140e:7b80:e2ba/64 Scope:Global
      inet6 addr: fe80::2e0:91ff:fe37:6a8d/64 Scope:Link
      inet6 addr: fd00:c47:3d3f:8cb2:2e0:91ff:fe37:6a8d/64 Scope:Global
      inet6 addr: 2a02:810c:800:2cdc:2e0:91ff:fe37:6a8d/64 Scope:Global
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:107179 errors:0 dropped:0 overruns:0 frame:0
      TX packets:61205 errors:1 dropped:0 overruns:1 carrier:0
      collisions:30 txqueuelen:1000 
      RX bytes:148550828 (148.5 MB)  TX bytes:4626197 (4.6 MB)

      lo        Link encap:Local Loopback  
      inet addr:127.0.0.1  Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING  MTU:65536  Metric:1
      RX packets:2894 errors:0 dropped:0 overruns:0 frame:0
      TX packets:2894 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:239665 (239.6 KB)  TX bytes:239665 (239.6 KB)

Running sudo lshw -C network gives:

   *-network
   description: Ethernet interface
   product: 191 Gigabit Ethernet Adapter
   vendor: Silicon Integrated Systems [SiS]
   physical id: 4
   bus info: pci@0000:00:04.0
   logical name: enp0s4
   version: 02
   serial: 00:e0:91:37:6a:8d
   size: 100Mbit/s
   capacity: 100Mbit/s
   width: 32 bits
   clock: 33MHz
   capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=sis190 driverversion=1.4 duplex=full ip=192.168.0.13 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
   resources: irq:19 memory:d8607000-d860707f ioport:1000(size=128)

   *-network DISABLED
   description: Wireless interface
   product: RT2790 Wireless 802.11n 1T/2R PCIe
   vendor: Ralink corp.
   physical id: 0
   bus info: pci@0000:03:00.0
   logical name: wlp3s0
   version: 00
   serial: 00:15:af:9e:0e:71
   width: 32 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=rt2800pci driverversion=4.2.0-16-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
   resources: irq:16 memory:d8300000-d830ffff

   *-network DISABLED
   description: Wireless interface
   physical id: 1
   bus info: usb@1:5
   logical name: wlx74da380a271c
   serial: 74:da:38:0a:27:1c
   capabilities: ethernet physical wireless
   configuration: broadcast=yes driver=rtl8192cu driverversion=4.2.0-16-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bgn

The lsusb of the dongle is

    Bus 001 Device 003: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]

I tried sudo rfkill unblock all and rfkill unblock 1, but that did not help.

Running sudo ifconfig wlx74da380a271c up lets the usb dongle appear in ifconfig, but does not change anything else:

     wlx74da380a271c Link encap:Ethernet  HWaddr 74:da:38:0a:27:1c  
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

Any help would be much appreciated.

1

By removing the module of the internal wifi card, the hard block on the usb dongle was lifted and now it works.

Solution based on How to disable built-in wifi and use only USB wifi card? (question and LnxSlck's answer).

Get the kernel driver name by running

        lspci -nnk | grep -iA2 net 

Take the name in the line "Kernel driver in use:". Make sure that it is the correct device (the wifi card and not e.g. the ethernet card). In my case it was rt2800pci. Then either remove it for testing temporarily using

        sudo modprobe -r rt2800pci

or permanentely by adding it to the blacklist

        sudo vi /etc/modprobe.d/blacklist.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.