21

New question following post Logitech MX Anywhere 2 mouse pairs but doesn't do anything

Pairing and connecting via built-in bluetooth manager and blueman works. also via commandline:

bluetoothctl

Output see below.

[MX Anywhere 2]# info DE:CE:68:71:F9:97
Device DE:CE:68:71:F9:97
    Name: MX Anywhere 2
    Alias: MX Anywhere 2
    Appearance: 0x03c2
    Icon: input-mouse
    Paired: yes
    Trusted: yes
    Blocked: no
    Connected: yes
    LegacyPairing: no
    UUID:                           (1800)
    UUID:                           (1801)
    UUID:                           (180a)
    UUID:                           (180f)
    UUID:                           (1812)
    UUID: Vendor specific           (00010000-0000-1000-8000-011f2000046d)
    Modalias: usb:v046DpB013d0007
[MX Anywhere 2]# paired-devices 
Device DE:CE:68:71:F9:97 MX Anywhere 2

What does not work is input, as in "the mouse doesn't move the cursor"

  • Did you look at bug 1098959, power monitor interfers with bt mouse? Try getting rid of power monitor app (reboot without battery?) and see if that helps. – ubfan1 May 7 '16 at 22:57
53

My device is a Surface Edition Bluetooth LE Arc Touch Mouse made by Microsoft.

I couldn't get it to connect with any distro I've tried over the past year, until OpenSuse Leap. Then I knew it was possible! But I like Ubuntu (I know I know)

Came across this thread and had everything looking exactly like your read out shows:

Name: Arc Touch Mouse SE
Alias: Arc Touch Mouse SE
Appearance: 0x03c2
 Icon: input-mouse
 Paired: yes  
 Trusted: yes
 Blocked: no
Connected: yes
LegacyPairing: no 

And Still NOTHING! No movement even though its clearly listed as paired, trusted, unblocked, and connected! I was about to give up for good but decided to try one last thing..

I deleted the device using "remove" and issued the following commands in this exact order which resulted in my device working! After a year of trying to find a way.

[bluetooth]# power off
[bluetooth]# power on
[bluetooth]# scan on
[bluetooth]# connect XX:XX:XX:XX:XX:XX
[Arc Touch Mouse SE]# trust
[Arc Touch Mouse SE]# connect XX:XX:XX:XX:XX:XX
[Arc Touch Mouse SE]# pair
[Arc Touch Mouse SE]# unblock
[Arc Touch Mouse SE]# power off
[bluetooth]# power on

So I can confirm that Ubuntu 16.04 does indeed support Bluetooth LE devices

  • Thanks for the answer! This solved all my problems with my MX Master mouse. It's crazy what's needed to get it working. – chuck Jun 6 '16 at 23:44
  • crazy amount of effort to get it going. Thanks! – Boyang Jul 27 '16 at 8:26
  • Great, thanks! Works with my MX Anywhere 2 / 16.04 / Kernel 4.8 (Yakkety). Note: the 2nd connect needs the XX:XX:XX:XX:XX:XX too. – linrunner Oct 28 '16 at 19:44
  • Thank you!!!! Finally worked for me. @linrunner is correct, 2nd connect needs ID. – markwatson Nov 7 '16 at 3:20
  • This worked, but it's completely stupid. How can bluetooth not work out of the box on a modern computer in 2017? – AutonomousApps Feb 26 '17 at 20:00
6

I managed to get my Anywhere MX2 to work on Ubuntu 16.04 thanks to this post.

After connecting the mouse in the "Bluetooth" configuration - it was still not working. Running bluetoothctl and "info " gave me this:

➜  ~ bluetoothctl 
[NEW] Controller 5C:51:4F:DC:FB:D0 ChromeLinux_CBDE [default]
[NEW] Device FB:59:51:BF:60:XX MX Anywhere 2
[bluetooth]# info FB:59:51:BF:60:XX
Device FB:59:51:BF:60:XX
    Name: MX Anywhere 2
    Alias: MX Anywhere 2
    Appearance: 0x03c2
    Icon: input-mouse
    Paired: yes
    Trusted: yes
    Blocked: no
    Connected: no
    LegacyPairing: no
    UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
    UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
    Modalias: usb:v046DpB013d0007

As you can see - my device was somehow not connected. And thus not responsive. What I did to make it work was only call 'connect':

[bluetooth]# connect FB:59:51:BF:60:XX
Attempting to connect to FB:59:51:BF:60:XX
[CHG] Device FB:59:51:BF:60:XX Connected: yes
Connection successful
[CHG] Device FB:59:51:BF:60:XX UUIDs: 00001800-0000-1000-8000-00805f9b34fb
[..snip..]
[CHG] Device FB:59:51:BF:60:XX Paired: yes

And after that everything "just works(TM)". Thanks for the useful additional information to this post.

  • I'm using Xenial (Xubuntu) . First connect didn't make it work for me. I had to follow James' instructions. – sdkks Jul 16 '17 at 4:41
1

In my case the issue that you can find here for 15.10 and the provided solution helped me:

hciconfig hci0 sspmode 1
hciconfig hci0 down
hciconfig hci0 up
  • That's what I get: Can't set Simple Pairing mode on hci0: Input/output error (5) – Michael Oct 2 '16 at 6:58

protected by Community Aug 5 '16 at 0:38

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.