0

I bought a brand new Lenovo laptop t460s which comes with Windows 10. I want to completely remove windows 10 and install Ubuntu. I accidentally installed Ubuntu 14.04 at first (Everything was working fine at this point as far as being able to boot/reboot).

When I installed 15.10 over 14.04 via USB, I used the "erase entire disk" option. Now I am no longer able to boot into Ubuntu (USB booting still works).

I tried reinstalling and erase entire disk installs of 15.10 via USB.

I tried disabling secure boot via BIOS.

I tried every boot option possible (currently I have 3, ubuntu, Windows Boot Loader and NVMe0 SAMSUNG).

I've also tried the Boot-Repair tool with the result here: http://paste.ubuntu.com/15268523/

I've tried enabling both Legacy and EFI boot modes.

I'm not sure what else to try and get the laptop to boot Ubuntu again.

1

As per the pastebin details - you haven't yet installed Ubuntu 15.10 it seems(as your grub entry still has try uubuntu) Moreover your pastebin also says that make sure your BIOS has the option to boot from the device which has the bootloader so please fix that in BIOS.

In case it's not working - try reinstall of Ubuntu 15.10 as that supports your skylake processor. Most probably your previous successful install of Ubuntu 14.04 LTS has created your default partitions (/ and swap) which you can re-use at the time of install.

| improve this answer | |
  • What setting do I need to change in BIOS? – pyCthon Mar 2 '16 at 18:09
  • there should be a boot order - usb, cd. hard drive etc...make sure hard driver which has your boot loader(grub) is at the top of the order – Ashu Mar 2 '16 at 18:11
  • They are all enabled, I tried switching the order and nothing happend. I also tried booting each option from the boot menu and nothing happend. – pyCthon Mar 2 '16 at 18:13
1

First, you say you were not able to boot Ubuntu after installing 14.04, but you don't give details. Any error message or symptom is a potentially important clue to what's wrong, so you must report this detail if you expect to get useful help.

Second, I recommend you not enable BIOS/CSM/legacy support unless you understand what you're doing. Although, in theory, Ubuntu should install in either mode, enabling the CSM creates a much more complicated boot path that provides more opportunities for things to go wrong. See this page of mine for details.

Third, it looks like your computer has one of the new Non-Volative Memory Express (NVME) devices. These are new enough that Linux support for them is still evolving. It could be that this is at least part of the problem; perhaps a new NVME-related bug appeared in 15.10 and is causing you problems.

Fourth, as a general rule, LTS releases like 14.04 are less buggy than non-LTS releases like 15.10. Since 14.04 worked for you, one obvious solution is to re-install it. If you're more adventurous, you could try a pre-release 16.04 version. (You can get a daily build here.)

Another option might be to try my rEFInd boot manager: Download the USB flash drive or CD-R image, create a boot medium, and boot it. If it works, it should show you an option to boot Ubuntu. If you can boot using that option, you can install the Debian package or PPA version and it should take over the boot process. I can't promise this will work, though -- if the problem is indeed a new kernel bug related to NVME, rEFInd won't help at all. If the problem is in GRUB, rEFInd might work around it.

| improve this answer | |
1

Try editing grub.cfg in /boot/grub/grub.cfg

You said you are able to boot Ubuntu 15.10 installed system through USB, didn't you?

| improve this answer | |
  • Just checked I don't have a /boot/grub/grub.cfg file. – pyCthon Mar 2 '16 at 18:31
  • There's a unicode.pf2, grubenv and a gfxblacklist.txt file – pyCthon Mar 2 '16 at 18:32
0

I'm not sure if this is the final solution or in addition to above steps/trys I listed.

I was able to get Ubuntu to finally install by booting off of a USB and running the disks tool to delete all previous partitions. I then installed Ubuntu from the boot and it worked!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.