1

I was dual booting Ubuntu 14.04 LTS and Windows 8.1. After one year on Ubuntu without using, Windows I decided to uninstall it with OS Uninstaller.

I used a Ubuntu live USB for did this and nearing the end, OS Uninstaller said "an error occured" followed by "successfully uninstalled Windows restart your computer".

I was a little confused as to whether this was a failure or a successful installation. I restarted, greeted by a black screen saying start pxe over ipv6

I restarted again, and went into the BIOS. In my boot options menu entries for Ubuntu and Windows, both say Drive not present.

I restarted once again but with a live USB this time. I checked my Hard Disk with Gparted and everything is the way I left it: Ubuntu and Windows.

So I used Boot Repair and I did a boot report here: http://paste.ubuntu.com/15265640 I'm in UEFI and the SecureBoot has been disabled for a year, since before I installed Ubuntu.

EDIT: @Ashu I can't boot Linux in recovery mode because its a live USB "try Ubuntu without install" but i tryed what you said.

When i run boot-repair he keep saying "GPT detected. Please create a BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag). This can be performed via tools such as Gparted. Then try again." but i have a boot partition so i don't understand.

Yeah i saw that but how can I put my grub2 in my MBR please ? When i run grub-customizer he said "grub-mkconfig couldn't be executed successfully. error message: /usr/bin/grub-probe: error failed to get canonical path of `/cow'." After that i can click on "environment setting" this is in the /cow (current) partition the line "DEVICEMAP_FILE" /boot/grub/device.map have a (!) and the line "OUTPUT_FILE" /boot/grub/grub.cfg have a (!) too. How fix this 2 lines ?

EDIT 2: What i have do : I followed all @Rod Smith step (my CSM is now disabled) except the last one rEFInd > I want keep my grub and I think I dont need this because I dont want a dual boot anymore. I have enter this commands lines (found here)

dd if=/dev/zero of=fat.fs bs=1024 count=SIZE how big do you want the filesystem; specify it as SIZE * 1024.
mkfs.vfat fat.fs formats the file as the filesystem FAT.
mount -o loop  fat.fs /mnt mounts fat.fs to /mnt.

and now my boot is in FAT16 but not FAT32. In Gparted i can only "Format to" but I can't change it without reformate the boot. I need fix this in FAT32 like you said. I used Super Grub2 Disk for enter in my Ubuntu OS (by the way "/efi/boot is missing" at launch) and followed all Rod's step. Boot Repair still don't work ( in live USB ) with "the recommend repair" always the same message. I think my only choice is to do it by myself with "Options advanced" but i need help for do it correctly (put the grub2 in the MBR).

A new Boot Report here: http://paste.ubuntu.com/15281116/

EDIT 3: Now I can boot on my Ubuntu without a CD-R or a USB but my partition boot efi is still in FAT16 and not in FAT32, how I can fix that for good ? I tryed to delete it, do a new one, format it in FAT32 but now this is again in FAT16.

  • 1
    You show gpt partitioning and have an ESP - efi system partition. But ESP must be FAT32 and somehow you changed to NTFS. Change back/not reformat with Disks in live installer. Then reinstall grub. Be sure to boot in UEFI mode. IF you really want BIOS boot you have to add a tiny 1 or 2MB unformatted partition with the bios_grub flag. Then reinstall in BIOS boot mode. – oldfred Mar 2 '16 at 17:19
  • Thanks for your time and your help. What is a GPT partitioning? and ESP = EFI ? OS Uninstaller did this. What partition must be in FAT32 ? How i reinstall grub ? What is a BIOS boot ? ( i know what is a BIOS but i don't know what is a BIOS boot ) – VincU Mar 2 '16 at 17:36
  • Too many questions, but go to end of this thread for all those answers on acronyms. Plus you may want to review thread to better understand UEFI, it is a lot. And many links for more info. ubuntuforums.org/showthread.php?t=2147295 – oldfred Mar 2 '16 at 20:21
  • Ok so now i understand. I dont want a BIOS boot, my bad. How can I keep back my ESP in FAT32 without reformat the partition ? – VincU Mar 3 '16 at 12:52
  • You should be able to use Disks in live installer and just change type or format, not the format option. The little gears icon under partitions, use edit partition. Type should be EFI System. Then see if it shows correctly and what files/folders you have in it. – oldfred Mar 3 '16 at 14:24
1

Oldfred's analysis in his comment is correct. Some background:

EFI (or UEFI, it's version-2.x variant) is a type of firmware. It's stored in a chip on the motherboard. EFI is a replacement for the old BIOS -- but unfortunately, many people (and even motherboard manufacturers) refer to their EFIs as "BIOSes," which just creates confusion because people drag in all sorts of incorrect BIOS assumptions. An EFI-based computer boots via a boot loader stored on the EFI System Partition (ESP), which is a FAT partition on the hard disk identified by a type code. (It shows up as having a "boot flag" set in parted or GParted, or as having a type code of EF00 in gdisk.) Complicating matters, most EFIs have a feature called the Compatibility Support Module (CSM), which enables them to boot BIOS-mode boot loaders. The CSM is to EFI as dosemu is to Linux, in that it lets a newer and more sophisticated environment run programs designed for an older and simpler one.

The CSM may be one small part of your problem, in that it's enabling you to boot your recovery tools in BIOS/CSM/legacy mode. That may be why you're getting the message about creating the "BIOS-Boot partition (>1MB, unformatted filesystem, bios_grub flag)" -- that partition is used only in BIOS-mode boots from a GPT disk. (If you've booted in EFI mode when you get that message, then Boot Repair has become hopelessly confused.) You may want to disable your CSM so that it can't cause any more problems. See this page of mine for more on the CSM and how it can create problems.

You can identify your boot mode by looking for a directory called /sys/firmware/efi. If it's present, you've definitely booted in EFI mode; and if it's absent, you've probably booted in BIOS mode. (There are ways to boot in EFI mode without that directory, but Ubuntu won't normally boot that way.)

Your Boot Repair output shows that /dev/sda1 should be an ESP:

Partition    Start Sector    End Sector  # of Sectors System
/dev/sda1           2,048       206,847       204,800 EFI System partition

Unfortunately, it's NTFS, not FAT:

sda1: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows Vista: NTFS

This could be a misidentification by Boot Repair. To double-check, you could try using blkid, as in sudo blkid /dev/sda1; or you could try mounting it and see what filesystem the kernel thinks is present by examining /etc/mtab. If this identification is correct, then chances are the utility you used to remove Windows damaged it. I recommend filing a bug report, since this is an extremely serious bug, if that's what's happened.

Unless this is a misidentification of the filesystem, your ESP is basically gone; you cannot recover it to its former state. Instead, you must install a fresh EFI-mode boot loader. To do this:

  1. Create a fresh FAT filesystem on /dev/sda1. Typing sudo mkdosfs /dev/sda1 from an emergency disk should do this; or you can use GParted if you prefer a GUI tool. Note that you'll also need to edit /etc/fstab on your Ubuntu root (/) filesystem (on /dev/sda7) to adjust the "UUID" (really a serial number) associated with /boot/efi, since creating a fresh filesystem will change that. You can learn the new "UUID" by typing sudo blkid /dev/sda1. You can put the /etc/fstab change off until later, if you like.
  2. Re-install an EFI boot loader for Linux. There are many ways to do this. The two easiest are:
    • Use Boot Repair -- If you can get an Ubuntu emergency disk to boot in EFI mode, it should be able to re-install GRUB and you'll be good to go. You say you've already tried this and it's failed, though. This likely means you booted in BIOS mode, although your Boot Repair output indicates an EFI-mode boot. Thus, either the repair attempt was from a different boot than the output or there's a bug in Boot Repair that's affecting your particular case.
    • Use rEFInd -- You can boot the computer using the CD-R or USB flash drive version of my rEFInd boot manager. (Download links for both are on this page. Once you've booted, you can install the rEFInd Debian package or PPA (after you create the FAT filesystem on the ESP). You should then be able to reboot and use rEFInd, rather than GRUB, to control the boot process.
  • I edited my post. – VincU Mar 4 '16 at 16:21
  • If Boot Repair isn't working, then try rEFInd. It's got many features useful for multi-booting, but it can be used to boot a single-OS Ubuntu system, too. You may need to type sudo mkdir /boot/efi to create that directory and edit the /etc/fstab file as noted above to get it to work correctly, though. – Rod Smith Mar 4 '16 at 17:24
  • So now i'm on my Ubuntu OS with rEFInd (with a CD-R),what I need to do exactly for put the Grub2 in the MBR ? If I install rEFInd on my Ubuntu, I don't need to put the Grub2 in the MBR ? – VincU Mar 4 '16 at 19:00
  • EFI boot loaders reside on the ESP, not in the MBR. From where you are now, you can either: (1) Install the rEFInd PPA or Debian package; or (2) Install the EFI version of GRUB (the grub2-efi-amd64 package, IIRC), type sudo grub-install, and then sudo update-grub. Option (2) is more likely to require tweaking and further troubleshooting. It's what Boot Repair is supposed to streamline, but that didn't work for you. – Rod Smith Mar 4 '16 at 21:18
  • I did the (2) step and now i can boot on my Ubuntu without CD-R or USB. But... my EFI partition is still in FAT16, i have deleted it, remake it in FAT32 and now the FAT16 is back. This is more slow in FAT16 ? – VincU Mar 4 '16 at 23:17
0

You should try to boot into Linux in recovery mode then root command prompt and try running boot-repair again. In your case grub2 should be installed in MBR. Also you should be using gparted for any disk partitioning work - that's also mentioned in your pastebin report.

To make things somewhat easier you can also make use of grub customizer

sudo add-apt-repository ppa:danielrichter2007/grub-customizer
sudo apt-get update
sudo apt-get install grub-customizer
grub-customizer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.