I've just reinstalled my Ubuntu 14.04.4 LTS (ah, much better!). My Canon MG5350 can print duplex and I used this all the time on the old installation, just to save paper. But now it won't anymore and I can't figure out why.

  1. The printer is connected via USB and Ubuntu found drivers for it automatically. The test page went well.
  2. Then I went into printer properties > printer options > ink type = Black and made another test print. That also worked well.
  3. Then I went into printer properties > printer options > 2-sided printing = long edge (standard). The test print is submitted, and the printer briefly wakes up, but then the job is gone from the queue without it being printed.
  4. When I reset 2-sided printing to "off", the test print works again.
    It's the same result when I want to print from a program (tested with a PDF file):

  5. 1-sided works (as per the configured default) when I use the system dialog to print.

  6. 2-sided fails when I use the system dialog and choose 2-sided printing (overriding the printer default). Same as in step 3 above = no print.

Given that this used to work on my previous Ubuntu installation, I know that I am not asking for the impossible here. Something about that 2-sided option is awry but I lack the printer configuration knowledge to find it.

Update: I know one thing that doesn't work: This old answer links to this manual installation guide, but when I submit a test page after completing that guide, the page is added to the printer queue (in Ubuntu) but the (physical) printer never notices this, so the job just sits there forever.

1 Answer 1


Okay, I found this solution that works for me. Basically, these are the required steps:

sudo add-apt-repository -y ppa:inameiname/stable
sudo apt-get -y install cnijfilter-common-64 cnijfilter-mg5300series-64

I honestly don't know what that repository is or why that one works better than the one provided with Ubuntu. I just see that this works better than anything else I've tried so far.

I also note that the PPA from michael-gruz/canon (mentioned here for example) doesn't seem to work with 14.04 (anymore?).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .