24

I am running Ubuntu 11.04 with gnome 2.3 and I would like my terminal window to be transparent.

The problems is the transparent settings in my terminal just shows the desktop background and not the actual windows that are opened behind the terminal. This works on my laptop where I have Xubuntu 11.10 and I see no reason why it should not work the same here.

This is how it should look:

This is how it looks:

  • As WarriorIng64 mentoned, this is typically because you are using ATI or nVidia graphics and don't have a driver installed. I've seen this frequently with a USB Linux I was giving to students. – Veazer Apr 25 '12 at 18:11
  • 1
    I would like this 'show desktop only' behavior by default, Its a little strange but when I had this bug I grew to really enjoy not seeing ugly other windows below the terminal and just getting an ice vista of my choosing, A window into serenity. – ThorSummoner Dec 1 '15 at 19:48
15

If you are using metacity make sure you have compositing enabled. To turn on run the following command in terminal:

gconftool-2 -s '/apps/metacity/general/compositing_manager' --type bool true
  • 1
    Didn't change anything. – prayagupd Jun 16 '14 at 4:05
52

Navigate through Edit Menu → Profile PreferencesBackground Tab → Click the Radio button for Transparent Background and adjust the slider.

terminal

  • 2
    Doesn't work in my case. This is what i tried first and nothing happens. – Alfie Jun 14 '15 at 15:31
5

It seems that you're not using compiz. You can install it by running:

sudo apt-get update && sudo apt-get install compiz

And if you already have it installed, try running:

compiz --replace 
  • I seem to have compiz installed, But compiz --replace just removed all window borders and it did not work. – zidarsk8 Oct 31 '11 at 17:31
  • @zidarsk8 It sounds like your system cannot support Compiz in its current state. Have you installed the necessary graphics drivers for your system to enable 3D effects? You may want to edit additional information about your graphics hardware back into the original question. – Christopher Kyle Horton Oct 31 '11 at 18:33
2

I'm a MATE user (under Linux Mint), and this issue was also window compositing for me. To turn it on in Mint 17/MATE, go to Menu -> Desktop Settings -> Windows, and check off the box that says "Use compositing", then restart mdm or reboot your machine.

  • This is the only answer that works for me, thanks! I didn't even need to restart anything. – Scz Dec 26 '16 at 13:27
1

Have you tried Edit>Profile Preferences > Background > Transparent Background

  • Yes, as you can see, my background "is transparent" but still shows only the desktop background, and no other windows that should be visible behind the terminal. – zidarsk8 Oct 31 '11 at 16:28
1

The top answer with metacity did not work for me in Raring (13.04), but I found a setting in dconf editor that did:

org.gnome.metacity.compositing-manager = True

Probably because of the move to a new settings system.

protected by RolandiXor Feb 21 '13 at 19:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.