1

This seems to happen in most every linux distro I try (haven't tried windows yet). I apologize in advance for the nonstandard situation in which it arose, but I will explain that after I explain the fundamental problem:

My CPU (Intel Core 2 Quad Q6600) keeps being throttled. When I boot up some distros which are more verbose during boot, I often see a message telling me that my CPU temperature exceed a threshold, and therefore has been throttled. This really seems improbable to me for a variety of reasons:

  1. The CPU is well-cooled, with two fans blowing directly onto its stock heatsink and one large fan exhausting. The whole system is very clean.

  2. The CPU PWM fan increases to maximum load during boot and during BIOS inspection, so I know that the BIOS seems to think this is a problem as well, but as soon as Ubuntu (or any other distro) boots, the fans die down. Various temperature reading programs in Ubuntu have shown me temps that - even under various benchmark loads which SHOULD be more stressful than Ubuntu's launch - do not exceed the recommended maximum for this CPU, which is something like 75C. They usually stay down in the 60s.

  3. During boot, idle, and benchmarking/burn-in tests, the exhaust fan is still expelling absolutely cool air.

For these and other reasons, I am almost 100% certain the CPU is falling victim to a faulty sensor, is there any way I can disable this safety feature in Ubuntu so that the software does not throttle my CPU?

Further information about my system which may be of note:

  • The CPU has been BSEL modded to run on a 1333mhz FSB rather than the stock 1066 FSB, resulting in a clock (listed in BIOS) of 3ghz instead of the 2.4ghz stock configuration.

  • The system is running Ubuntu 15.10 off a liveCD image.

  • 1
    I suspect it's getting hotter than you realise. A FSB overclock on is nothing to sneeze at, and you're still using the stock heatsink. That said, I don't know anything about the software mechanism you describe or how to disable it, I'm afraid. – thomasrutter Mar 2 '16 at 5:34
  • You could disable pstate but I've never done that on a live session. – mchid Mar 2 '16 at 10:59
  • Are you sure the maximum temp is actually "recommended"? – mchid Mar 2 '16 at 11:02
  • Is this answer any use to you: askubuntu.com/a/523690/57576 ? – andrew.46 Mar 2 '16 at 21:49
  • Feel free to post that as the answer to help other people out who have this problem and include how you did it on a live session. – mchid Mar 6 '16 at 16:53
2

You could disable pstate but I've never done that on a live session. – mchid Mar 2 at 10:59

This is the right path forward for anyone else who comes looking here. As I said in the comments as well, the strategy for anyone seeking to do this (and to my forgetful self in the future when I inevitably end up wanting to do this on another of my "funny" PCs) would be to follow the advice set forth in a phoronix article "...fall-back to using ACPI CPUfreq on modern Intel systems is by setting intel_pstate=disable as a kernel command-line argument when booting the modern kernel."

On a live session, you can edit the options by pressing F6 and then by pressing ESC.

Add the following option to the command line displayed and then proceed as normal:

intel_pstate=disable

link here: www.phoronix.com

and here: BootOptions - Community Help Wiki

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.