I replaced a buggy Windows Vista installation with Ubuntu. All works fine except that the main HD where I had all my files are now inaccessible. Here is the error message I get:

Error mounting: mount exited with exit code 13: ntfs_attr_pread_i: ntfs_pread failed: Input/output error
Failed to read NTFS $Bitmap: Input/output error
NTFS is either inconsistent, or there is a hardware fault, or it's a
SoftRAID/FakeRAID hardware. In the first case run chkdsk /f on Windows
then reboot into Windows twice. The usage of the /f parameter is very
important! If the device is a SoftRAID/FakeRAID then first activate
it and mount a different device under the /dev/mapper/ directory, (e.g.
/dev/mapper/nvidia_eahaabcc1). Please see the 'dmraid' documentation
for more details

Is it necessarily a hardware problem? If not, is there a way to repair the HD from Ubuntu?


6 Answers 6


ntfsfix worked for me :

sudo ntfsfix /dev/sdb1

Provided in the ntfs-3g package.

  • 1
    after following askubuntu.com/a/364298/50885 follow above to get USB mount :)
    – CoDe
    Apr 3, 2014 at 10:52
  • This command is completing without problems but still even sais : Mounting volume... OK but i still get the same output as in the question when i try to mount
    – YourHelper
    Sep 16, 2022 at 15:23

chkdsk /R is a pretty important command when things get hairy with NTFS. Unfortunately I don't know of a Linux tool that comes close to covering everything it does. In short, to run it, you're going to need some sort of Windows recovery disk.

If you don't have one to hand, there's an ISO offered up in a thread on another set of support forums (see the first answer).

There are tools like ntfsfix (part of the ntfsprogs package) that can do surface checks on NTFS disks but they don't tend to be able to fix the drives.

  • 3
    You could install VirtualBox and an XP on it. Prevent the drive mounting in fstab, (if USB mount: add the USB filter in VBox so that XP sees the "raw" USB drive), mount the drive on XP and run chkdsk on it.
    – Déjà vu
    Jan 6, 2014 at 2:46
  • @ringø what if windows cannot mount it ? it shows that your new device wont work properly message, so how can i check it ? Aug 31, 2016 at 1:03

NTFS is a closed source Microsoft file system, and you'll need Windows to repair it, by running chkdsk /f, as suggested. If the problem is hardware related, you'll have to replace the hdd.

  • Not necessary only Windows.
    – BVengerov
    Jan 13, 2017 at 7:52

i have encountered a similar situation once,then i kept the harddisk on windows,then a popup appeared asking to check the disk for errors.

if didn't ask goto computer,right click on the drive and then click on properties,there would be a tab "tools"

disk checking

select "check now"

this type of errors occur if you dont safely remove harddisks.



So I was facing, more or less, the same issue. Around 12 files on the NTFS partition of my HD were inaccessible nor could they be deleted. Got to know about them through backintime's error logs. Fired up my Window 7 on vmware, accessed that folder containing the files through shared folder and copied them to a new folder. But for some reason I was not able to delete those files (0 bytes) from Windows 7 either. No surprise there, the OS did not have low-level access to those files.

ntfsfix did not fix it, said nothing was wrong, and fsck said all's cool with the the device. I could not chkdsk /R because the files were shared through network drive. And I didn't have Window 7 installed on my physical machine.

Solution (steps for vmplayer, but could easily be followed for virtualbox):

  1. Add a new HD to your vm (had to start vmplayer as root)
  2. When prompted for the disk type choose physical disk
  3. Choose the correct device (for this reason vmplayer was started as root)
  4. Select "Use individual partitions"
  5. Select the partition containing the buggy files
  6. Finish adding
  7. Start the vm

For me Windows 7 detected the new partition and did a checkdisk on boot. It had a lot of (Index) cleaning to do. The buggy files were gone. And the problem solved.

  • I don't see an option to add a physical disk in VirtualBox. There must be a way but for whatever reason the Mac version I'm using isn't offering it to me. Apr 8, 2016 at 5:57

I got this after newly fomratting an SD card as ntfs, all I had to do what umount it first.

sudo umount -l /dev/sdx1

then mount worked again

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .