1

I just got a Samsung M267x series (M2675FN) monochrome multifunction printer today. I cannot seem to install the drivers correctly. It's starting to really frustrate me.

I have tried the suld repository (and multiple drivers)

as well as the download from the samsung site.

When I use the suld repository, I am able to do a test print page that tells me "if you can read this, you are using the wrong driver for your printer" If I try to print, the printer wakes up, the document shows in the print queue for a moment, then disappears and says the print job was completed, though nothing has happened.

when using the driver downloaded from the samsung site, when I add the printer through the print config, it returns a message stating that I am missing /usr/lib/cups/filter/rastertospl

I have tried the suggestion found online to make a symbolic link, but I'm not sure that the code I found was specific enough for my computer. When that didn't work, I rm the symbolic link.

Any suggestions?

0

Finally, the suld repository held the answers.

FIRST, delete the printer from the printer configuration if you have already added it. NEXT delete any drivers you have already tried on your computer for the printer in question.

Then follow the instructions at http://www.bchemnet.com/suldr/index.html I used Ubuntu software manager. In Ubuntu you go to the software center, then from the top menu, Edit>software sources>other sources>add volume. Here you add " deb http://www.bchemnet.com/suldr/ debian extra " Then download and save the key file, found at the same index link above. To import the key file to ubuntu software center, go to the software center then Edit>software sources>authentification>import key file The packages now should appear in your software center (refresh maybe needed) Access them by clicking the down arrow next to the box icon that says all software on the top left. Click on Bchemnet.

Find the appropriate driver using the list on the repository site under the tab 'supported printers'

Then download the correct driver from within the software center.

For the M2675FN, this was the Samsung unified linux driver 2 - suld-driver2-1.00.36

After 3 hours of this frustration, I'm quite happy to share how I finally fixed it! Best of luck.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.