3

I am building the Vulkan driver over here from source on 15.10. It seems to work for a couple of simple examples so far but there is a mention that it requires DRI3 to be enabled here: "The intel driver needs DRI3, so either enable it via xorg.conf, or remove intel_drv.so and use the modesetting driver instead". I don't know how to do that.

I did try and add an /etc/X11/xorg.conf with this section:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "DRI"    "3"
EndSection

but on reboot my /var/log/Xorg.0.log has no reference to DRI3, and several to DRI2:

[     4.059] (II) glamor: EGL version 1.4 (DRI2):
[     4.064] (II) Loading sub module "dri2"
[     4.064] (II) LoadModule: "dri2"
[     4.064] (II) Module "dri2" already built-in
[     4.169] (II) modeset(0): [DRI2] Setup complete
[     4.169] (II) modeset(0): [DRI2]   DRI driver: i965
[     4.169] (II) modeset(0): [DRI2]   VDPAU driver: i965
[     4.180] (II) GLX: Initialized DRI2 GL provider for screen 0

Any help would be appreciated.

  • This question has nothing to do with 15.10, since that ppa is only for Xenial, that is the development version of Ubuntu. And in this sense, this question is also off-topic here. – dadexix86 Mar 1 '16 at 22:52
  • @dadexix86 I am building the driver in question from source on 15.10, not using that pre-built PPA. I just mentioned the PPA for some context. As a reminder, the (on-topic) question is simply "How is DRI3 enabled for Intel drivers running on a Haswell iGPU in Ubuntu 15.10?" – ahcox Mar 1 '16 at 22:57
  • This changes the context entirely, because for 15.10 you need to upgrade your graphic stack to latest kernel (>=4.3) and some very recent mesa driver with DRI3 enabled (and I do not know how to do it). I suggest that you modify your question explaining and contextualizing a bit more what you are trying to do (people who might be able to help you, might actually not read your comment). – dadexix86 Mar 1 '16 at 23:06
  • @dadexix86 Okay, editing it now in another tab. Thank you :). – ahcox Mar 1 '16 at 23:07
2

Adding the code below to /etc/X11/xorg.conf worked for me:

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "SwapBuffersWait" "0"
   Option      "DRI" "3"
EndSection
  • Thank you for your answer :). The only change from what I tried is a single line which seems more of an optimisation than something that would make a not-work / work difference. Can you confirm 1. You are on 15.10. 2. You have a Haswell iGPU. 3. You have run substantial Vulkan demos/apps. 4. You checked that DRI3 was actually in use via /var/log/Xorg.0.log or some better method. – ahcox Jun 16 '16 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.