0

I don't have a problem with ubuntu, everything is working fine, but I'm wondering if it can be more power-efficient.
For now I have installed tlp, powertop, and cpu-frequency-scaling-indicator. When all are set in power saving mode my laptop runs for about 2-2,2 hours. That's not bad (windows 7 isn't much better), but according to powertop and Power Statistics energy consumption is pretty high, 20-23 Watts.
Here comes my question. Can I do something more to decrease energy consumption? Or is this a normal consumption?
I'm using Sony-Vaio notebook with Intel i5 cpu and nVidia 310m gpu, system: ubuntu 15.10.
Thank you for help.

EDIT

Output for

  "sudo prime-select intel":

Info: the current alternatives in use are: ['nvidia-340', 'nvidia-340'] Info: selecting nvidia-340-prime for the intel profile update-alternatives: using /usr/lib/nvidia-340-prime/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode update-alternatives: using /usr/lib/nvidia-340-prime/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in manual mode

I'm sorry, I do not really get how text formatting works here.

12
  • Please edit your question and add output of lspci -k | grep -EA2 'VGA|3D' terminal command.
    – Pilot6
    Mar 1, 2016 at 21:12
  • Thank you for your answer. 01:00.0 VGA compatible controller: NVIDIA Corporation GT218M [GeForce 310M] (rev a2) Subsystem: Sony Corporation Device 9069 Kernel driver in use: nvidia
    – sigmaalpha
    Mar 1, 2016 at 21:20
  • Is it the full output?
    – Pilot6
    Mar 1, 2016 at 21:30
  • Yes, this is full output.
    – sigmaalpha
    Mar 1, 2016 at 21:31
  • That is weird. You should have an Intel adapter too.
    – Pilot6
    Mar 1, 2016 at 21:33

3 Answers 3

0

It looks like your Nvidia adapter is always in use.

  1. Install nvidia-340 driver.

    sudo apt-get install nvidia-340 nvidia-prime
    
  2. Reboot.

  3. Select the Intel adapter

    sudo prime-select intel
    

If it does not work make sure that the Intel adapter is not disabled in bios.

2
  • I did as you said. That's the output: "Info: the current alternatives in use are: ['nvidia-340', 'nvidia-340'] Info: selecting nvidia-340-prime for the intel profile update-alternatives: using /usr/lib/nvidia-340-prime/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in manual mode update-alternatives: using /usr/lib/nvidia-340-prime/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in manual mode". I wasn't able to change any gpu option in BIOS. I could only switch IntelVirtualisationTechnology on what I did.
    – sigmaalpha
    Mar 1, 2016 at 21:58
  • Please DO NOT POST OUTPUTS TO COMMENT BOX. Edit your question instead.
    – Pilot6
    Mar 1, 2016 at 22:05
0

One way to save ~1 Watt is to enable Aggressive Link Power Management. ALPM is now available for newer SATA controllers that use the Advanced Host Controller Interface. Note that some controllers may go into a low power state incorrectly and this ends up causing data loss. Ubuntu has the ability to use ALPM but it it disabled by default since it can cause data loss on some machines. Since there is a chance that this can cause data loss do not enable it unless you have backups of your data and are willing to take the risk.

To enable:

echo SATA_ALPM_ENABLE=true | sudo tee /etc/pm/config.d/sata_alpm

I also developed "powerstat", a lightweight tool to measure power consumption, this also maybe worth using.

sudo apt-get install powerstat
powerstat

Finally, to track down power hogging processes, it may be worth reading the more detailed Ubuntu power management wiki page: IdentifyingIssues

I'd recommend using tools such as eventstat to identify any processes that are causing excessive wakeups, as well as forkstat to see if any rapid process creation is occurring.

-1

Hardware wise buy a SSD drive. A laptop that normally gets 2 hrs can get about 2 - 3 hrs with an SSD drive. Actually most new laptops are reported to run with 4 to 8 hrs of battery life. I feel your pain. Maybe just buy a few extra batteries for your battery hogging laptop.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.