0

I'm running on an HP 8730w laptop with aRV635/M86 [Mobility Radeon HD 3670], video card and upgraded from 14.04 to 15.10, and X is using the VESA driver, and not giving me anything but 1400x1050 resolution. This isn't even the right aspect ratio so things look funny, and the screen definiely supports higher resolutions. I've tried the fglrx-updates drivers, those simply don't work, and the radeon driver unloads itself after some lines like:

[    14.225] (II) Module fbdevhw: vendor="X.Org Foundation"
[    14.225]    compiled for 1.17.2, module version = 0.0.2
[    14.225]    ABI class: X.Org Video Driver, version 19.0
[    14.225] (EE) open /dev/fb0: No such file or directory
[    14.225] (EE) open /dev/fb0: No such file or directory
[    14.225] (EE) Screen 0 deleted because of no matching config section.
[    14.225] (II) UnloadModule: "radeon"

I'm kinda at my wits end. Purged all my X related packages and reisntalled the, tried every fglrx driver I can find, etc... Any suggestions?

0

This problem was one of the reasons why I downgraded to 14.04. I couldn't get my Radeon HD9700 to work hybrid with Intel. FGLRX, tried everything, including manually installing. The kernel doesn't seem to support it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.