10

The the following to add my user to the group:

sudo usermod -aG vboxusers karl

Got the error message:

usermod: group 'vboxusers' does not exist

My groups are as following:

karl adm cdrom sudo dip plugdev lpadmin sambashare vboxsf

I'm using VirtualBox 5.0.14, Ubuntu 14.04, Guest Additions 5.0.14 and Extension Pack 5.0.14. I can see my USB device in my host OS.

21

Both your virtualbox and extension versions match. That's a critical part of the process.

To solve the group problem use the commands sudo addgroup vboxusers and sudo adduser USERNAME vboxusers where USERNAME is your user name. Do both these things on the host. logout and back in for this to take effect.

Note that vboxsf which you have listed in your groups is actually a filesystem type used by the mount command.

Download the correct extension pack from this page and when prompted open it with Virtualbox.

The final step is to setup USB support on your VM, opening setings for the VM in virtualbox with the VM shutdown, selecting USB and enabling USB 2.0 and adding and activating filters as needed. See Below:

VB-USB

Note: In the recent past USB 3.0 (XHCI) controllers were not supported but this functionality was added in Virtual Box 5.0

Further information is available in the official documentation.If that doesn't sort it for you, drop me a comment and I'll expand on this.

Sources:

https://www.virtualbox.org/wiki/Downloads

https://help.ubuntu.com/community/VirtualBox/USB

https://help.ubuntu.com/community/VirtualBox/SharedFolders

  • Hello! I've upgraded to 5.0.14 on both VirtualBox, Guest Additions and The Extension Pack. Exactly the same! Also stupid question, but am I to add the group vboxusers on the host or guest? Also I keep reading that the vboxusers group should automatically be created? – Karl Morrison Mar 1 '16 at 2:45
  • Ok got it working now thanks! Was on the host I was to do this (even when the group didn't exist). – Karl Morrison Mar 1 '16 at 2:49
  • Sorry for the delay I had to replace a failing drive in my machine. Yes. The host you add the vboxusers group to. I'll edit the answer to make it more clear. I'm glad you got it sorted! – Elder Geek Mar 1 '16 at 4:52
1

In my case the issue was in wrong chipset settings in guest OS (Windows). Once I chose ICH9 I could see a lot of usb devices connected to my pc.

0

I also could not see USB devices. I ran through the usual suspects:

  • Extension pack not installed/wrong version.
  • User not member of vboxusers group.
  • Kernel modules not installed.

After I exhausted all of these, I simply purged the VirtualBox package, reinstalled it, and suddenly I could see all of my USB devices.

I'm not sure how this fixed things for me, but it did.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.