28

When I type Ctrl+Alt+s on a window, the body of the window rolls up. How can I disable this shortcut, that I want to use for another purpose in my emacs configuration?

22

You can change it in System Settings → Keyboards → Shortcuts → Windows.

| improve this answer | |
9

It works in Ubuntu 13.04 and 14.04 LTS.

Go to System-settings -> Keyboard (menu) -> Shortcuts (button) -> Windows (tab) and then select Toggle-shaded-state and press backspace to disable it, and close the window.

| improve this answer | |
  • 4
    This cannot be reporduced in 18.04. I get System-settings -> Devices -> Keyboard -> Keyboard Shortcuts In the Keybaoard Shortcuts page are various sections, one of which is Windows... and while there are options like "Resize Window", "Toggle maximization state", etc... there is no "Toggle shaded state." This is frustrating because I'm trying to use Intellij-Idea which has Ctrl-Alt-S hardcoded as the shortcut to its Settings... Instead, I get cyclic "adjust window size" action of Ubuntu. – TheGeeko61 Jul 27 '18 at 21:36
  • 3
    For ubuntu 18.04 use dconf reset /org/gnome/desktop/wm/keybindings/toggle-shaded to disable ctrl+alt+s. BTW I am not able to post this as answer cause of my low reputation... – user1185087 Feb 22 '19 at 16:59
  • 1
    @user1185087 your advice helped! You've got >100 rep, maybe now you could post it as a new answer? – Robert K. Bell Jun 9 at 0:57
  • 1
    @RobertK.Bell 101 rep seams not enough to add an answer :( – user1185087 Jul 8 at 17:52
0

In 18.04, I used dconf-editor to change /org/gnome/desktop/wm/keybindings/toggle-shaded from ['<Control><Alt>s'] to ['<Control><Shift><Alt>s'] so that emacs will get my regex search keystroke, but I can still (will I ever?) rollup the window shade.

c.f. ctrl + alt + S on ubuntu 18.04 triggers a screen size toggle but is not listed in keyboard settings

| improve this answer | |
0

When You're using Compiz, then goto CompizConfig Settings Manager -> General -> General Options -> Key Bindings -> Toggle Window Shaded -> Edit -> empty the shortcut s.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.