1

I recently dual boot my system (HP-ab034tx) with Ubuntu and Windows 10. Unfortunately I am having trouble with wireless connection on Ubuntu. The connection is being disconnected in a while and also the Wi-Fi range is very little whereas it seems to be working great on Windows.

I think the problem is regarding the wireless drivers so I tried updating these. I still can't connect my system.

Wireless card adapter : Realtek RTL8723BE 802.11 bgn Wi-Fi Adapter

1

Most certainly a driver/power management issue... assuming yr laptop is an HP Pavilion 14-ab000 Notebook PC series

[Preliminary rant] As is often the case HP seems not to have any interest in providing solutions to the Linux desktop user community, so as far as I know you will not be able to find a Linux driver specific to yr wireless card adapter on their site. [End of rant]

First] Check out those old and new AU answers, where you can get a Realtek RTL8723BE 802.11 bgn Wi-Fi Adapter driver from Github. Both answers are essentially the same but the more recent will take you step by step through terminal commands.
Note: To open a terminal window, press ALT+CTRL+T -- when done close it with CTRL+D

Second] If that does not solves yr problem, you may want to try to hack into the power management options of your wireless chipset. Power Management for Realtek chipsets such as yrs sometimes lead to poor performance, slowness in connecting to a network and erratic behavior.

The hack consists in disabling yr wireless adapter's sleep feature. In the terminal, type:

$ echo "options rtl8723be fwlps=0" | sudo tee /etc/modprobe.d/rtl8723be.conf

This hack is copied verbatim from AndyAndy on this AU's post. It also gives you the source for a recent firmware for your wireless adapter.

Instead of rebooting yr box, try (in the terminal):

$ sudo rmmod rtl8723be && sudo modprobe rtl8723be

Wait for 30 minutes or so, to see whether yr wireless connection is really stable. If not reboot and check yr wireless connection again.

Third] As a last resort I would download the above mentioned firmware (I have not tested it). If you do, place it in directory /lib/firmware/rtlwifi/ and reboot.

As before wait for 30 minutes or so, to see whether yr wireless connection is really stable. If not scream loud enough so somedody can hear you and resume troubleshooting.

  • Look at the logs ( grep wlan /var/log/kern.log ) before and after each change. – waltinator Feb 29 '16 at 16:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.