5

An upgrade from Ubuntu 14.04 LTS to Ubuntu 15 failed. Package repair hangs at this point:

Setting up resolvconf (1.77ubuntu1) ...
Processing triggers for resolvconf (1.77ubuntu1) ...
resolvconf: Error: /run/resolvconf/interface
either does not exist or is not a directory
dpkg: error processing package resolvconf (--configure)

How can I get past this point?

sudo apt-get remove resolvconf

I want to remove ubuntu-base, which seems not to be a good idea. I see this Debian Bug report.

The problem was probably triggered by a manual attempt on my part to start networking using old-school editing of /etc/resolv.conf

closed as off-topic by Zanna, Fabby, user535733, Rinzwind, David Foerster Feb 22 '18 at 23:54

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Fabby, user535733, Rinzwind, David Foerster
If this question can be reworded to fit the rules in the help center, please edit the question.

  • What's the output of ls -l /run/resolvconf/interface ..also after changing /etc/resolv.conf manually you could just do sudo resolvconf -u do make resolvconf creating it again..resolvconf depends on lsb-base so removing it won't be a good idea.. – heemayl Feb 29 '16 at 4:07
  • sudo resolvconf -u does not help. /run/resolvconf/ does not exist. – Bryce Feb 29 '16 at 4:38
  • You can try sudo mkdir -p /run/resolvconf/interface and re-running your package repair. If that fails it might be difficult to fix and you may need to remove and re-install a ton of packages and you may have a broken system. See also - blog.bodhizazen.net/linux/… – Panther Feb 29 '16 at 5:32
  • I ran the repair script, except this time did not first start networking at that boot. Now it worked. – Bryce Mar 1 '16 at 6:30
  • 2
    @Bryce, which repair script? – Velkan Sep 12 '16 at 9:42